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AVAYA MESSAGING FEATURE DESCRIPTION GUIDE
Messaging is a feature rich application which offers a solution for virtually any organization or situation. The productivity
enhancing nature of Messaging derives from the dynamic environment of all the feature which can be fully customized
and mixed-and-matched to meet the specific needs of an organization.
Since the feature library of Messaging platform is vast, it is easy to become overwhelmed by the large number of settings
and options available to you as an administrator or an end user. To simplify both the configuration and usage of the
common features within Messaging, this guide separates each feature and explains in detail how they can be
implemented.
Having to consult vast amounts of technical documentation to implement a single feature can be time consuming and
inefficient. By organizing all the necessary materials for you, the Feature Description Guide will make the administration
process a breeze and will also offer you end user training materials which you may utilize during training sessions or
distribute directly to the end users.
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Notice
While reasonable efforts have been made to ensure
that the information in this document is complete and
accurate at the time of printing, Avaya assumes no liability for any errors. Avaya reserves the right to make
changes and corrections to the information in this document without the obligation to notify any person or
organization of such changes.
Documentation disclaimer
“Documentation” means information published in varying mediums which may include product information,
operating instructions and performance specifications
that are generally made available to users of products.
Documentation does not include marketing materials.
Avaya shall not be responsible for any modifications,
additions, or deletions to the original published version
of Documentation unless such modifications, additions,
or deletions were performed by or on the express
behalf of Avaya. End User agrees to indemnify and
hold harmless Avaya, Avaya's agents, servants and
employees against all claims, lawsuits, demands and
judgments arising out of, or in connection with, subsequent modifications, additions or deletions to this documentation, to the extent made by End User.
Link disclaimer
Avaya is not responsible for the contents or reliability of
any linked websites referenced within this site or Documentation provided by Avaya. Avaya is not responsible
for the accuracy of any information, statement or content provided on these sites and does not necessarily
endorse the products, services, or information
described or offered within them. Avaya does not guarantee that these links will work all the time and has no
control over the availability of the linked pages.
Warranty
Avaya provides a limited warranty on Avaya hardware
and software. Refer to your sales agreement to establish the terms of the limited warranty. In addition,
Avaya’s standard warranty language, as well as information regarding support for this product while under
warranty is available to Avaya customers and other
parties through the Avaya Support website: https://support.avaya.com/helpcenter/ getGenericDetails?detailId=C20091120112456651010 under the link “Warranty
& Product Lifecycle” or such successor site as designated by Avaya. Please note that if You acquired the
product(s) from an authorized Avaya Channel Partner
outside of the United States and Canada, the warranty
is provided to You by said Avaya Channel Partner and
not by Avaya.
“Hosted Service” means an Avaya hosted service subscription that You acquire from either Avaya or an
authorized Avaya Channel Partner (as applicable) and
which is described further in Hosted SAS or other ser-

vice description documentation regarding the applicable hosted service. If You purchase a Hosted Service
subscription, the foregoing limited warranty may not
apply but You may be entitled to support services in
connection with the Hosted Service as described further in your service description documents for the applicable Hosted Service. Contact Avaya or Avaya
Channel Partner (as applicable) for more information.
Hosted Service
THE FOLLOWING APPLIES ONLY IF YOU PURCHASE AN AVAYA HOSTED SERVICE SUBSCRIPTION FROM AVAYA OR AN AVAYA CHANNEL
PARTNER (AS APPLICABLE), THE TERMS OF USE
FOR HOSTED SERVICES ARE AVAILABLE ON THE
AVAYA WEBSITE, HTTPS://SUPPORT.AVAYA.COM/
LICENSEINFO UNDER THE LINK “Avaya Terms of
Use for Hosted Services” OR SUCH SUCCESSOR
SITE AS DESIGNATED BY AVAYA, AND ARE APPLICABLE TO ANYONE WHO ACCESSES OR USES
THE HOSTED SERVICE. BY ACCESSING OR USING
THE HOSTED SERVICE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF YOURSELF
AND THE ENTITY FOR WHOM YOU ARE DOING SO
(HEREINAFTER REFERRED TO INTERCHANGEABLY AS “YOU” AND “END USER”), AGREE TO THE
TERMS OF USE. IF YOU ARE ACCEPTING THE
TERMS OF USE ON BEHALF A COMPANY OR
OTHER LEGAL ENTITY, YOU REPRESENT THAT
YOU HAVE THE AUTHORITY TO BIND SUCH
ENTITY TO THESE TERMS OF USE. IF YOU DO
NOT HAVE SUCH AUTHORITY, OR IF YOU DO NOT
WISH TO ACCEPT THESE TERMS OF USE, YOU
MUST NOT ACCESS OR USE THE HOSTED SERVICE OR AUTHORIZE ANYONE TO ACCESS OR
USE THE HOSTED SERVICE.
Licenses
THE SOFTWARE LICENSE TERMS AVAILABLE ON
THE AVAYA WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO, UNDER THE
LINK “AVAYA SOFTWARE LICENSE TERMS (Avaya
Products)” OR SUCH SUCCESSOR SITE AS DESIGNATED BY AVAYA, ARE APPLICABLE TO ANYONE
WHO DOWNLOADS, USES AND/OR INSTALLS
AVAYA SOFTWARE, PURCHASED FROM AVAYA
INC., ANY AVAYA AFFILIATE, OR AN AVAYA CHANNEL PARTNER (AS APPLICABLE) UNDER A COMMERCIAL AGREEMENT WITH AVAYA OR AN
AVAYA CHANNEL PARTNER. UNLESS OTHERWISE
AGREED TO BY AVAYA IN WRITING, AVAYA DOES
NOT EXTEND THIS LICENSE IF THE SOFTWARE
WAS OBTAINED FROM ANYONE OTHER THAN
AVAYA, AN AVAYA AFFILIATE OR AN AVAYA
CHANNEL PARTNER; AVAYA RESERVES THE
RIGHT TO TAKE LEGAL ACTION AGAINST YOU
AND ANYONE ELSE USING OR SELLING THE
SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR
AUTHORIZING OTHERS TO DO SO, YOU, ON

BEHALF OF YOURSELF AND THE ENTITY FOR
WHOM YOU ARE INSTALLING, DOWNLOADING OR
USING THE SOFTWARE (HEREINAFTER
REFERRED TO INTERCHANGEABLY AS “YOU” AND
“END USER”), AGREE TO THESE TERMS AND CONDITIONS AND CREATE A BINDING CONTRACT
BETWEEN YOU AND AVAYA INC. OR THE APPLICABLE AVAYA AFFILIATE (“AVAYA”).
Avaya grants You a license within the scope of the
license types described below, with the exception of
Heritage Nortel Software, for which the scope of the
license is detailed below. Where the order documentation does not expressly identify a license type, the
applicable license will be a Designated System License
as set forth below in the Designated System(s) License
(DS) section as applicable. The applicable number of
licenses and units of capacity for which the license is
granted will be one (1), unless a different number of
licenses or units of capacity is specified in the documentation or other materials available to You. “Software” means computer programs in object code,
provided by Avaya or an Avaya Channel Partner,
whether as stand-alone products, pre-installed on hardware products, and any upgrades, updates, patches,
bug fixes, or modified versions thereto. “Designated
Processor” means a single stand-alone computing
device. “Server” means a set of Designated Processors
that hosts (physically or virtually) a software application
to be accessed by multiple users. “Instance” means a
single copy of the Software executing at a particular
time: (i) on one physical machine; or (ii) on one
deployed software virtual machine (“VM”) or similar
deployment.
License types
Designated System(s) License (DS). End User may
install and use each copy or an Instance of the Software only: 1) on a number of Designated Processors
up to the number indicated in the order; or 2) up to the
number of Instances of the Software as indicated in the
order, Documentation, or as authorized by Avaya in
writing. Avaya may require the Designated Processor(s) to be identified in the order by type, serial number, feature key, Instance, location or other specific
designation, or to be provided by End User to Avaya
through electronic means established by Avaya specifically for this purpose.
Concurrent User License (CU). End User may install
and use the Software on multiple Designated Processors or one or more Servers, so long as only the
licensed number of Units are accessing and using the
Software at any given time. A “Unit” means the unit on
which Avaya, at its sole discretion, bases the pricing of
its licenses and can be, without limitation, an agent,
port or user, an e-mail or voice mail account in the
name of a person or corporate function (e.g., webmaster or helpdesk), or a directory entry in the administrative database utilized by the Software that permits one
user to interface with the Software. Units may be linked

to a specific, identified Server or an Instance of the
Software.
Named User License (NU). You may: (i) install and use
each copy or Instance of the Software on a single Designated Processor or Server per authorized Named
User (defined below); or (ii) install and use each copy
or Instance of the Software on a Server so long as only
authorized Named Users access and use the Software.
“Named
User”, means a user or device that has been expressly
authorized by Avaya to access and use the Software.
At Avaya’s sole discretion, a “Named User” may be,
without limitation, designated by name, corporate function (e.g., webmaster or helpdesk), an e-mail or voice
mail account in the name of a person or corporate function, or a directory entry in the administrative database
utilized by the Software that permits one user to interface with the Software.
Copyright
Except where expressly stated otherwise, no use
should be made of materials on this site, the Documentation, Software, Hosted Service, or hardware provided
by Avaya. All content on this site, the documentation,
Hosted Service, and the product provided by Avaya
including the selection, arrangement and design of the
content is owned either by Avaya or its licensors and is
protected by copyright and other intellectual property
laws including the sui generis rights relating to the protection of databases. You may not modify, copy, reproduce, republish, upload, post, transmit or distribute in
any way any content, in whole or in part, including any
code and software unless expressly authorized by
Avaya. Unauthorized reproduction, transmission, dissemination, storage, and or use without the express
written consent of Avaya can be a criminal, as well as a
civil offense under the applicable law.
Virtualization
The following applies if the product is deployed on a virtual machine. Each product has its own ordering code
and license types. Note, unless otherwise stated, that
each Instance of a product must be separately licensed
and ordered. For example, if the end user customer or
Avaya Channel Partner would like to install two
Instances of the same type of products, then two products of that type must be ordered.
Third Party Components
“Third Party Components” mean certain software programs or portions thereof included in the Software or
Hosted Service may contain software (including open
source software) distributed under third party agreements (“Third Party Components”), which contain
terms regarding the rights to use certain portions of the
Software (“Third Party Terms”). As required, information regarding distributed Linux OS source code (for
those products that have distributed Linux OS source
code) and identifying the copyright holders of the Third
Party Components and the Third Party Terms that

apply is available in the products, Documentation or on
Avaya’s website at: https:// support.avaya.com/Copyright or such successor site as designated by Avaya.
The open source software license terms provided as
Third Party Terms are consistent with the license rights
granted in these Software License Terms, and may
contain additional rights benefiting You, such as modification and distribution of the open source software.
The Third Party Terms shall take precedence over
these Software License Terms, solely with respect to
the applicable Third Party Components to the extent
that these Software License Terms impose greater
restrictions on You than the applicable Third Party
Terms.
The following applies only if the H.264 (AVC) codec is
distributed with the product. THIS PRODUCT IS
LICENSED UNDER THE AVC PATENT PORTFOLIO
LICENSE FOR THE PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT
RECEIVE REMUNERATION TO (i) ENCODE VIDEO
IN COMPLIANCE WITH THE AVC STANDARD (“AVC
VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT
WAS ENCODED BY A CONSUMER ENGAGED IN A
PERSONAL ACTIVITY AND/OR WAS OBTAINED
FROM A VIDEO PROVIDER LICENSED TO PROVIDE
AVC VIDEO. NO LICENSE IS GRANTED OR SHALL
BE IMPLIED FOR ANY OTHER USE. ADDITIONAL
INFORMATION MAY BE OBTAINED FROM MPEG
LA, L.L.C. SEE HTTP://WWW.MPEGLA.COM.
Service Provider
THE FOLLOWING APPLIES TO AVAYA CHANNEL
PARTNER’S HOSTING OF AVAYA PRODUCTS OR
SERVICES. THE PRODUCT OR HOSTED SERVICE
MAY USE THIRD PARTY COMPONENTS SUBJECT
TO THIRD PARTY TERMS AND REQUIRE A SERVICE PROVIDER TO BE INDEPENDENTLY
LICENSED DIRECTLY FROM THE THIRD PARTY
SUPPLIER. AN AVAYA CHANNEL PARTNER’S
HOSTING OF AVAYA PRODUCTS MUST BE
AUTHORIZED IN WRITING BY AVAYA AND IF
THOSE HOSTED PRODUCTS USE OR EMBED CERTAIN THIRD PARTY SOFTWARE, INCLUDING BUT
NOT LIMITED TO MICROSOFT SOFTWARE OR
CODECS, THE AVAYA CHANNEL PARTNER IS
REQUIRED TO INDEPENDENTLY OBTAIN ANY
APPLICABLE LICENSE AGREEMENTS, AT THE
AVAYA CHANNEL PARTNER’S EXPENSE,
DIRECTLY FROM THE APPLICABLE THIRD PARTY
SUPPLIER.
WITH RESPECT TO CODECS, IF THE AVAYA
CHANNEL PARTNER IS HOSTING ANY PRODUCTS
THAT USE OR EMBED THE G.729 CODEC, H.264
CODEC, OR H.265 CODEC, THE AVAYA CHANNEL
PARTNER ACKNOWLEDGES AND AGREES THE
AVAYA CHANNEL PARTNER IS RESPONSIBLE FOR
ANY AND ALL RELATED FEES AND/OR ROYALTIES. THE G.729 CODEC IS LICENSED BY SIPRO
LAB TELECOM INC. SEE WWW.SIPRO.COM/CONTACT.HTML. THE H.264 (AVC) CODEC IS LICENSED

UNDER THE AVC PATENT PORTFOLIO LICENSE
FOR THE PERSONAL USE OF A CONSUMER OR
OTHER USES IN WHICH IT DOES NOT RECEIVE
REMUNERATION TO: (I) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC
VIDEO”) AND/OR (II) DECODE AVC VIDEO THAT
WAS ENCODED BY A CONSUMER ENGAGED IN A
PERSONAL ACTIVITY AND/OR WAS OBTAINED
FROM A VIDEO PROVIDER LICENSED TO PROVIDE
AVC VIDEO. NO LICENSE IS GRANTED OR SHALL
BE IMPLIED FOR ANY OTHER USE. ADDITIONAL
INFORMATION FOR H.264 (AVC) AND H.265 (HEVC)
CODECS MAY BE OBTAINED FROM MPEG LA,
L.L.C. SEE HTTP:// WWW.MPEGLA.COM.
Compliance with Laws
You acknowledge and agree that it is Your responsibility for complying with any applicable laws and regulations, including, but not limited to laws and regulations
related to call recording, data privacy, intellectual property, trade secret, fraud, and music performance rights,
in the country or territory where the Avaya product is
used.
Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications system by an unauthorized party (for
example, a person who is not a corporate employee,
agent, subcontractor, or is not working on your company's behalf). Be aware that there can be a risk of Toll
Fraud associated with your system and that, if Toll
Fraud occurs, it can result in substantial additional
charges for your telecommunications services.
Avaya Toll Fraud intervention
If You suspect that You are being victimized by Toll
Fraud and You need technical assistance or support,
call Technical Service Center Toll Fraud Intervention
Hotline at +1-800-643-2353 for the United States and
Canada. For additional support telephone numbers,
see the Avaya Support website: https://support.avaya.com or such successor site as designated
by Avaya.
Security Vulnerabilities
Information about Avaya’s security support policies can
be found in the Security Policies and Support section of
https:// support.avaya.com/security.
Suspected Avaya product security vulnerabilities are
handled per the Avaya Product Security Support Flow
(https:// support.avaya.com/css/P8/documents/
100161515).
Downloading Documentation
For the most current versions of Documentation, see
the Avaya Support website: https://support.avaya.com,
or such successor site as designated by Avaya.

Contact Avaya Support
See the Avaya Support website: https://support.avaya.com for product or Hosted Service notices
and articles, or to report a problem with your Avaya
product or Hosted Service. For a list of support telephone numbers and contact addresses, go to the
Avaya Support website: https://support.avaya.com (or
such successor site as designated by Avaya), scroll to
the bottom of the page, and select Contact Avaya Support.
Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this site, the Documentation, Hosted Service(s), and product(s) provided by Avaya are the
registered or unregistered Marks of Avaya, its affiliates,
its licensors, its suppliers, or other third parties. Users
are not permitted to use such Marks without prior written consent from Avaya or such third party which may
own the Mark. Nothing contained in this site, the Documentation, Hosted Service(s) and product(s) should be
construed as granting, by implication, estoppel, or otherwise, any license or right in and to the Marks without
the express written permission of Avaya or the applicable third party.
Avaya is a registered trademark of Avaya Inc.
All non-Avaya trademarks are the property of their
respective owners. Linux® is the registered trademark
of Linus Torvalds in the U.S. and other countries.
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AUTOMATIC SPEECH RECOGNITION
(ASR)
Ch. 1 - Automatic Speech Recognition (ASR)
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Automatic Speech Recognition (ASR)

Introduction
Automatic Speech Recognition (ASR) is a vital component of the UC system. ASR allows the system to recognize human
speech, so that users to speak contact names and menu selections, instead of entering them through the telephone
keypad.
Messaging uses Media Resource Control Protocol (MRCP) for communications with the ASR services provider.

Visual Guide

ASR
SR allows
ll
user’s
’ vo
voice
to replace DTMF input

Traditional access to UC
Server via DTMF input

Dialing a contact, accessing messages
or the TUI menus through voice is
possible using the ASR engine

ASR provides the base for all speech recognition functions, such as Speech Contacts and Speech Commands. ASR
interprets a user’s voice input as a number or a character (e.g. alphabet) based on the grammar settings on the server.
This allows users to speak the name of the contact they want to dial, or to say a number instead of pressing the digit on
the telephone keypad. By replacing traditional input with speech, users can efficiently find what they were looking for. It
also give users easy access to the system without having to use their hands.
For specific features such as Speech Commands, please refer to the appropriate chapters in this guide.

Requirements

Avaya Messaging Feature Description Guide

Requirements

Details

License

ASR License

Software

Officelinx version 8.0 - 10.7
Messaging version 10.8 or higher

20

Automatic Speech Recognition (ASR)

Server Configuration
Server configuration for ASR is completed in several steps.
First, verify the Messaging license that you have. In order to use ASR, you must have the ASR license.
Once the license is confirmed, make the necessary settings in the Messaging Administrator and from the ASR
Configurator.

License Confirmation
Setting up ASR begins by making sure that you have purchased and installed the license. ASR is provided under an add-on
to the standard license and must be purchased separately.
The procedure to check your license depends upon the type of license you have; the Sentinel license if or the Avaya
WebLM license. Use the appropriate section for your site.
With the license confirmed, launch the Avaya Messaging Administrator to configure the application.

Sentinel License
Check the UC License Upgrade Utility under Programs > Messaging.
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Ensure that the information in the ASR section of the license
contains the appropriate details.
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WebLM License
Check the UCLicenseWebLM under Start > Programs > Avaya Messaging.
Go to the ASR tab and ensure that the information
contains the appropriate details.

IX Messaging Admin Configuration
1.

Open Messaging Admin and go to Configuration >
Advanced. In the right pane, set Voice recognition
mode to Nuance.

2.

Once this option has been set, go to Company
Properties.

3.

Right-click on the company that will use ASR. Choose
Properties.

4.

Go to the Speech Options tab and enable Voice Recognition.
Enable the other features as required.
Confirm names in voice recognition: The system will confirm a
recognized name no matter what
Allow barge-in voice recognition: Callers can say a name while the
system is playing a greeting or a prompt.
Allow barge-in confirm names: The system allows you to interrupt
to confirm that a name that it found is correct.
Allow Say Operator: For the systems with a default operator
defined, it will recognize the word “Operator” as a dial request for
the operator.
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ASR Configurator
From the Voice Verification section of the interface, you can specify the
sensitivity level for the feature via Security Level. The number of
questions the voice server will ask during login can also be controlled
through Number of Questions.
Security Level has 5 levels to choose between. These range from VeryHigh to Medium Low. Refer to the chart below to see the difference
between each level, along with the typical False Acceptance rate (the
rate in which the system will log in a wrong person to the mailbox).
Since the FA rate for Very-High is the lowest, it may seem logical to
always choose this option. However, while the number of FAs
decreases, the number of FRs (False Rejection) increases. At the
highest security setting, people may have problems logging into their
mailbox if their voice changes even slightly. This might be caused by a
sore throat, added environmental noise or using a different device. It is
up to the site administrator to choose the setting which best fits the
company’s requirements.
Number of Questions: Choose the number of random questions that
the system will ask when verifying the user's voice print. The system can be set to ask between 1 and 3 questions.
There are three types of questions that the system will ask at random.

•
•

Full Name: The system will ask the user to speak out their full name associated with the mailbox.

•

Random 4 Digit Number: The system will generate a random 4 digit number and ask the user to repeat the
numbers.

Recognition Keywords: The system will randomly choose a keyword from the database (defined by the
administrator) and ask the user to repeat the word.

The default setting will ask a minimum of 1 and maximum of 3 questions. This means that if the answer to the first
question was satisfactory, the user will be logged in. If not, the system will ask a second question. If the answer to the
second question was satisfactory, the user will be logged in. If not, the system will ask the final question. If the answer to
the final question was satisfactory, the user will be logged in. If not, the verification process will fail and the user will
either be disconnected from the system, or be asked to manually enter their password through DTMF keys depending on
the security settings of the site.
Security Level:
Security Level

Typical Usage Recommendation

FA Rate

Very-High

Access to mailbox accounts with critical information

0.1Internet to
0.2Internet

High

Access to mailbox accounts with high privilege

0.2Internet to
1.5Internet

Medium-High

Access to typical mailbox accounts

1.5Internet to
3Internet

Medium

Access to typical mailbox accounts in open environment

3Internet to
5Internet

Medium-Low

Generic access where Voice Verification is used for convenience

5Internet to
7Internet

Caution: The Voice Verification feature will shortly be discontinued.
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MRCP Configurator
The ASR feature should work well immediately after installation. However, if there are issues with the feature, such as
excessive requests to “Please repeat that”, the administrator can adjust the program settings.
1.

On the hard drive where Messaging is installed, open the \UC\MRCP folder. Run the UCMRCPConfig application.

2.

The ASR parameters are shown. Change these settings as necessary to correct any issues with the feature.

Speech Voice Format: Select the desired format for voice traffic:
0 - Linear 128kbps, 1 - Mulaw 64kbps, or 2 Alaw 64kbps. Mulaw is recommended.
Log Level: Provides control over the amount of information collected by the system regarding ASR. The
amount of detail in the log increases with the selection as follows: FATAL (least data collected), ERROR,
WARN, USER_ERROR, USER_WARN, STATUS, INFO, D_INFO, VD_INFO and ALL (most data collected).
Choosing NONE disables logging.
Sensitivity: This adjusts the ability of the system to handle line noise. Drag the slider to select a value between
5 and 30. Higher settings make ASR less sensitive to noise.
For TAPI/Dialogic boards, set this to 14. For Rhetorex boards, set to 20.
Acceptance Level: Drag the slider to select a value between 50 and 100. The ASR server recevies the voice
stream and returns a score (as a %) regarding how certain it is that it understood. Scores at or above the value
selected here are processed normally. Scores below this minimum are compared to the Rejection Level.
Rejection Level: Drag the slider to select a value between 40 and 80 (must be lower than the Acceptance Level).
Scores below the Acceptance level but above the Rejection Level mean that the ASR server is uncertain
whether it understood. The caller will be prompted to verify the result. Scores below the Rejection level are
unuseable and stop the process.
ASR Number of Results: Specify the number of results to return (minimum 1) when more than one directory
entry is found. For example, if there are 10 John Smiths at the company, this value will limit the number of
results offerred to the caller (4 by default) instead of listing all of them.
Click Defaults to return all values to their base values.
When ready, click Apply.
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Introduction
When a call is made through the auto attendant to your external number, or if you dialed a person from an external
number through the auto attendant, you will now have the ability to perform basic call control actions right from your
external number. This allows you to take advantage of the call control features without having to be tied down to your
work station or a specific telephone system. Any telephone that is capable of DTMF input will be able to send commands
to the Messaging server as long as the call itself was connected through the Messaging server. ECC (Enhanced Call
Control) also includes the Call Handoff feature which will supplement the transfer features.

Visual Guide
Business is always on the move, so it is not always ideal to
stay idle. This is true even when you’re on the phone. The
important call you’re answering from your workstation
phone may be preventing you from other tasks or being
elsewhere. You could ask the caller to call you back on
your cell phone or ask if it would be okay for you to call
them back on the other line but this would usually break
the flow of conversation and is not ideal for majority of
situations.
The hand off feature was added to the Messaging system
to remedy such an issue. You can now seamlessly transfer
your current ongoing phone call at your desk to another
device (e.g. cell phone, another station, etc) without any
interruption. The person you are talking to will most likely
not even notice the transfer since the call is instantly
connected to your second line the moment you confirm.
A call may be managed through Handoff no matter what
device is being used as long as the call is managed
through the Messaging system (i.e. calls are made through
auto attendant). As long as such a condition is met, and
the user has the permission to transfer between devices,
the user may initiate a Handoff through the iLink Pro
Desktop.
As you can see from the flowchart, the calls are not
interrupted in any way. While traditional call transfers put
the second party on hold during the transfer, there is no
“buffer” required during a Handoff. The call is seamlessly
transferred between the devices, and the audio stream
moves from one device to another without any pauses in
between. The second party is unlikely to notice that the
Handoff has occurred at all.
The server is able to establish a connection by recognizing
the answered status on the second device, which means
that the Handoff feature automatically moves the audio
stream from first device to the second automatically right
after the second device answers.
Since the call is still being monitored by the system, the
user is free to perform a Handoff repeatedly as long as
he/she has access to the iLink Pro Desktop call control or
ECC.
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Server Configuration
The server side configuration for enabling Enhanced Call Control is very simple. The administrator must enable the
service on a Feature Group, then the mailboxes within that FG will have access to the feature. The administrator may also
change the ECC trigger key from the Company settings as well.
Note: Users must log out and log back into iLink Pro Desktop to access Call Handoff from the client
application after you have enabled the feature.

Company
From Company> Call Options tab, modify the Enhanced Call CAontrol
Trigger Key as desired. The trigger can consist of any DTMF keys. This key is
set to ** by default.
Note: Please ensure that Enhanced Call Control Trigger Key does not
overlap with any other keys.

Feature Group
From Feature Group > Transfer Options tab, enable either or both of
Internal Extension or External or External/Internal (FindMe)
Extension checkbox from the Enhanced Call Control section.
Internal Extension will enable the ECC for user's dedicated internal
device only.
External or External/Internal (FindMe) Extension will enable the ECC
for both internal and external device as long as the call is made to the
user through auto attendant.
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User Guide
Enhanced Call Control is meant for use on an external number. If you are at your typical location (i.e. your work station),
using the telephone’s own call control or iLink Pro Desktop’s call control will be more efficient and easier. However, you
will have access to this feature even on your desktop phone if the administrator has enabled it for you.
Keep in mind that pushing the right command keys is vital for Enhanced Call Control since there is no simple means to
monitor the call’s status without iLink Pro Desktop. When the correct command key is pressed, you will hear the menu
options available to you and the other person on the line will be on hold and will hear the hold music.
While ECC allows you to control the call from the phone itself, the Call Handoff feature can also be managed by iLink Pro
Desktop's Call Manager feature. Please refer to the section at the end of this guide for more information.
When the ECC is available for your current call, you will hear an audio indicator at the beginning of the call. If you do not
hear this at the beginning of the call, you will not have access to ECC.

ECC Command List
** - Default Access Code. Push ** to enter the ECC menu. The other party will automatically be put on hold. This access
code may be changed by the system administrator.
1 - Retrieve the current call (stop the hold)
2 - Transfer the current call to another number
3 - Hand off the current call to another device
4 - Disconnect the other person on hold and return you to the Auto Attendant
# - Disconnect the current call for both parties

Initiating a Handoff to Predefined Numbers
By default, iLink Pro Desktop will allow you to hand off the calls to numbers
assigned to your current location. Select the number you wish to hand off the call
to by clicking on the appropriate entry.
Once you initiate the handoff, the selected number will ring. When the new
extension is answered, the old connection will be terminated and the conversation will continue on the new device only.
You will still retain the ability to control the call from iLink Pro Desktop, which means that you can freely handoff the
phone call to any destination as many times as you wish.
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Initiating a Handoff to Custom Numbers
Note: You cannot handoff a call to a custom number through ECC. You may only perform this action from
iLink Pro Desktop.
When you wish to handoff to a number that isn’t defined under your current
locations, you can choose the Handoff to... option then manually define the
destination.
Select one of the following radio buttons, then either enter or select the
destination.

•

Mailbox: Use this option to handoff the call to another mailbox. You can use
the Find button to search for a mailbox if you do not know the number.

•

Phone: Use this option to handoff the call to an external phone number.
Clicking on build will allow you to separately define country & area codes.

•

Location: Use this option to handoff the call to a chosen location’s default
number.
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Introduction
Navigating through the Voice Menu or the TUI can sometimes be difficult when you cannot freely enter the DTMF keys.
When you’re on a cellphone, for example, it is often difficult to navigate through DTMF input due to the ergonomics of cell
phones. Messaging now supports a Voice Navigation function where the users may speak the numerical choice rather
than to enter it on their phone. This will allow the users to freely navigate through the entire system without having to
enter a single key.

Visual Guide
The user will dial into the system as he/she would normally do. Once
connected, the system will list all the menu options as usual. The user
speaks the menu item number of his/her choice. The system accepts the
Speech Command as a valid entry and performs the action associated
with the number.

Requirements
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Server Configuration
In order to enable Speech Commands for the users, Speech Recognition must be turned on at the Company level. This
requires an ASR license. Then give permission to the FG and the Mailboxes as appropriate.

Company Properties
Go to IX Messaging Admin > Company, and on the Speech Options tab,
ensure that Voice Recognition is enabled for the company.
Note: All users that wish to use Speech Commands must be setup
under a company that has ASR capabilities.

Feature Group Properties
From Messaging Admin > Feature Group, on the Speech Options tab,
enable the Enable Speech Command checkbox.
With this option enabled, individual mailboxes associated with this FG
will be able to turn Speech Commands on and off.
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Mailbox Properties
From Messaging Admin > Mailbox, on the Speech Options tab, enable
the
Enable Speech Command checkbox to allow this particular mailbox
user to use the Speech Command feature. You must repeat this step for
all users that wish to use this feature.

Customize TUI Configuration
Users may occasionally need to turn off the Speech Command
temporarily if they are in an environment with too much noise. Voice
selection of menu items can be interrupted, or another person’s loud
voice may be accepted as an entry instead.
To allow callers to temporarily disable this function, add the
Disable Speech Command action to the TUI that the caller will be using.
When a user selects this action from the TUI, the Speech Command
feature will be disabled for that session. Users will be able to use Speech
Command again the next time they log into the system. Using this action
only temporarily disables the feature.
Note: If a user doesn’t have access to Speech Command feature,
this action will be a null action for them.
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User Guide
When you log into the phone system, you may sometimes find it difficult to navigate through the menus using the
telephone keypad. For example, if you are using a hands-free head set while driving, having to press the keys on your cell
phone can be a dangerous distraction.
To avoid this situation, you can utilize the Speech Command feature which allows you to navigate through the phone
system menus without having to press any keys. You speak the number of the commands you wish to send instead of
pressing the corresponding button. This allows access to all of the options available on your phone system without
having to press a single button, giving you a true hands-free telephone experience.

Basic TUI Navigation
When you are given a choice of menu items, simply say the number of the corresponding action.
Warning: Do not repeat the actual name of the action. You must say the number of the action instead.
It is vital that you clearly say the number. The system will automatically match the sound with a number without
confirmation, so in order to properly navigate through the menus, you must pronounce the numbers as clearly as
possible.
Note: Control keys can only be accessed through DTMF input. It is not compatible with speech commands.

Temporarily Disable Speech Command
You may wish to disable Speech Command from time to time due to high amount of background noise. If you have the
Disable Speech Command action in your TUI, you will be able to disable the Speech Command feature for a single
session. When you select this action, Speech Command will become invalid right away, and the system will only accept
telephone key input. The feature will remain disabled until you are disconnected from the system.
Note: When you log into the system again, the Speech Command feature will be available again.
Note: Location of the disable action will vary depending on the TUI associated with your mailbox.
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Introduction
For many business users, their list of contacts can easily grow to such a length that finding any one person can be
difficult. To make this easier, the contact list can be speech enabled to allow finding a person through voice alone.
In order for a user to use this feature, configuration changes must be made on both the server and the client
applications. Please follow this guide exactly as explained to enable the speech contact function on your system.

Visual Guide
SpeechContact compilescontact data
withinthe GrammarFile, allowing users
to speakthe nameof the contact instead
of entering it thr
ough a keypad
.

ASR allows user’s voice to
replace DTMFinput.

Usersare ableto dial a contact,
or senda messageto a recipient,
by saying the person
’s name.

Having easy access to contacts is essential for people on the go. Spending a few minutes just to select someone to call or
to send a message to is not very efficient. Speech Contacts makes it easy for users to locate a contact by enabling voice
searches. Once the user sets a contact to be speech enabled, they will be able to find that person within the TUI.

Requirements
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Server Configuration
For the following steps, launch the Messaging Admin program.

Procedure
1.

Go to Company properties, and open the Speech Options tab.
Specify the following:
Voice Recognition: Enable to activate the ASR engine in the
automated attendant.
Confirm Names in Voice Recognition: Allows the confirmation of
the name spoken by the caller.
Allow Barge-In in Voice Recognition: The caller can interrupt the
system (e.g. say "Yes" or "No") during voice recognition.
Allow Barge-In in Name Confirmation: This allows the caller to
interrupt the system (e.g say "Yes" or "No") as it performs name
confirmation.
Allow Say Operator: The caller can say “Operator” to be
transferred to the operator if one has been setup on the system.

2.

From the Contact Priority dropdown list, select which of your contacts
(Public, Private or None) are more important when doing speech
recognition of contacts.
For example, if in a mailbox you choose to speech enable both Public
and Private contacts (Mailbox > Mailbox Options screen) and the
number of users (company mailboxes + private contacts + public contacts) exceeds the number of allowable users
on the license, you must disable either the Enable ASR for Public Contacts or Enable ASR for Private Contacts
according to the selection you have made in this dropdown list.
For example, selecting Private in this dropdown list, and disabling Enable ASR for Private Contacts on the
Mailbox > Mailbox Options screen will give priority to Public contacts.

3.

Save any changes.

4.

Open the Mailbox of the person who will use this feature.
Go to the Speech Options tab and specify the following:
Enable ASR for Public Contacts: Enable to implement ASR
capabilities for public contacts.
Enable ASR for Private Contacts: Enable to implement ASR
capabilities for private contacts.
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5.

Move onto the Advanced tab. Ensure that Messaging & Collab is
selected under Desktop Capabilities.

6.

Save the Mailbox settings.
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User Guide
Enabling Speech Contacts allows you to quickly and easily get in touch with your contacts through the TUI (Telephone
User Interface). Instead of having to enter multiple keys to find a contact, you say the name instead.
Only speech enabled contacts may be accessed through speech. You must ensure that the contacts are enabled for
speech before using the feature.

Enabling Speech Contacts
You can enable speech for your contacts
individually from each contact’s properties.

If you have a long list of contacts, it is quicker to
use the batch function.
1.

Click on the Contacts icon, then click on the
Speech Enable Contacts button.

2.

Select the Enable Speech radio button.

If you wish to enable speech for all of your contacts, click on
the
Apply To All Contacts button.
If you wish to enable speech for only certain contacts:
1.

Populate the uppermost listbox with contacts. Choose
from the Select from: dropdown list, or in the Search field,
enter the contact name that you want to add and click the
Search button.

2.

Add contacts from the upper listbox to the bottom by
enabling the checkbox beside the contact, then clicking the
Add button.

3.

When all desired contacts have been added, click on the
Apply to Selected Contacts button to apply the changes.

Note: If you wish to disable the speech contact feature
for large number of contacts, repeat the above process
but choose Disable Speech radio button instead.
When you open a contact that has speech enabled, you will see
that Speech enable this contact is checked. You may freely modify individual entries by enabling or disabling this
checkbox.
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Introduction
This feature allows you to increase the security level of Voicemail and Faxes that are transferred via email by storing all
the files on the server itself. Instead of the attachments being sent and received, the sender’s attachment is stored on the
server while the receiver gets a link to access the file.
The below process illustrates an example of how this can be implemented. Due to the variation between different sites,
following these steps exactly as shown (especially with regards to the URL and folder paths) may prevent the feature
from working properly on your own system. A professional technician with networking knowledge who understands the
process would be able to configure the settings necessary for your own system setup.
Also, please keep in mind that the configuration procedure will differ depending on the version of your IIS. In general,
Windows 2003 and XP will use IIS 6 while Windows 2008 and Windows 7 use IIS 7, which changes the interface you must
configure the feature from.
Note: Voice messages which are listened to through the telephone using the Weblinks action link within the
email will not automatically change the read status of the voice message. Therefore, listening to message in
this fashion will not extinguish the message light on integrated environments. The end users have the
option of marking the message as read through the options available at the bottom of the Weblinks
message. Performing such an action will extinguish the message light on integrated environments if the
message is the last unread message.

Configuration Process
The exact procedure to setup Weblinks depends upon which version of IIS (Internet Information Services) is installed on
the server.
Warning: Only follow the procedure that is relevant to your system. Do Not perform both IIS setup
procedures.

If the server has IIS 7 installed, begin the process on page 47.
If the server has IIS 6 installed, begin the process on page 48.
Regardless of which version of IIS is present, the Messaging setup remains the same. Once the appropriate version of IIS
has been configured, continue with the Messaging setup on page 49.
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Configuration with IIS 7
Warning: Use these instructions only if you have IIS 7 or later on your system. If you have IIS 6, use the section
Configuration with IIS 6 on page 48.
1.

In order to utilize Weblinks, you must first
confirm that you have the necessary
Windows components installed for IIS.
You will need HTTP Redirection and CGI
enabled within IIS.
This image shows adding the component
from
Windows Server 2008, which occurs under
Role management.

If you are utilizing Windows 7, you will see this screen, available from
Control Panel > Programs & Features > Windows Features.

Important: Continue with the section Messaging Configuration on page 49.
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Configuration with IIS 6
Warning: Use these instructions if have IIS 6 on your system. If you have IIS7, then use the section
Configuration with IIS 7 on page 47.
1.

Open the Start menu.
Right-click My Computer then choose Manage.

2.

On the left-hand side, select
Web Service Extensions.

3.

On the right-hand side, select
All Unknown CGI Extensions.
Click on Allow.

4.

You will get the following warning.
Click Yes to accept the changes and continue.

5.

Repeat steps step 1- step 4 for All Unknown ISAPI Extensions.

Important: Continue with the section Messaging Configuration on page 49.
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Messaging Configuration
Once the appropriate version of IIS has been setup, continue with the Messaging configuration.
1.

From IXM Admin > Configuration > VPIM/
SMTP, change the value of HTML Content to
True.

2.

In order to utilize the Weblinks function, the mailbox has to be
associated with the Feature Group that has the function enabled.
From Messaging Admin > PBX > Company > Feature Group, go to
the Synchronization Options tab and select the type of messages
you wish to use Weblinks with from the dropdown menu.

3.

If a user does not utilize IMAP CSE Synchronization between their
Messaging mailbox and the mail server account, you may opt for
the forwarding method.
From Messaging Admin > PBX > Company > Mailbox, open the
properties of the mailbox you wish to enable Weblinks for, then go
to the Message Options tab. Create an entry to forward the
emails. When the mailbox is associated with the Feature Group
that has the Weblinks enabled, as shown in previous step, you
can enable the HTML Content checkbox. Be sure to leave the
Attachment checkbox disabled if you wish to send the URL only.

Warning: Please keep in mind that this step is only for users who
will be using email forwarding instead of IMAP CSE
Synchronization. If you configure forwarding for users who are
using IMAP CSE Synchronization, there will be an infinite loop of
messages. You should either use IMAP sync or forwarding but
never both for the same mailbox.
4.

When all your server side configuration has been completed,
restart the server computer.
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5.

Locate the webmailconfig.exe file in the Messaging folder (by default, this is
C:\UC).
From Windows, go to Start > Run and enter the full path and file name in the
space provided. Add the /i parameter, and the URL of the server where the
files will be kept.
For example:
C:\UC\webmailconfig.exe /i user.erb.com
Click OK and the program will automatically configure the remaining settings.

6.

Stop and restart the World Wide Web Publishing Service on the computer to complete the setup.
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Weblinks Example
The following is an example of how the attachments are handled using this function. The email itself only contains the
text of the message. The attachment is left on the server. If you were to forward this email to someone with no
permission to access the mail server, they would not be able to listen to the message. While the email is forwarded, the
attachment itself remains secure on the server.
By using the Playback buttons, the voice message can be played through the current device, or the telephone associated
with the user’s default extension. Additional buttons allow the message to be Mark Read or Deleted from the voice
server. A call to the sender can also be initiated by clicking the UC Dial (dial through the Messaging voice server) or Dial
(dial through a configured device, such as a cell phone when out of the office) buttons.

The View button opens an new window in the browser. This window contains playback controls for the message.

Fax messages processed through Weblinks will behave in the same manner. The attachment remains on the server while
only links to view the message are sent to the user.
Forwarded messages will contain links which are only viewable by authorized users.
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Introduction
The Action Schema option causes tags to appear in the subject line of emails that contain voice messages, or those that
denote missed calls. Users can click on these buttons to playback voice messages, or to immediately place a telephone
call to the contact.
Warning: This feature is only compatible with email programs that support DKIM verification.
Warning: Actions Schema is not supported on systems using IMAP Synchronization.

Enable Action Schema
Turn on the Action Schema option through the Messaging Admin program.
1.

Start Messaging Admin and open the Mailbox folder.

2.

Double-click one of the listed mailboxes, and open the Message Options tab.
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3.

Click Add to create a new Address, or select an existing address and choose Edit.

4.

Select which Message Types (voice and missed calls) will add a tag to the message in the email subject line.
Configure the remaining settings as required, and enable the Action Schema checkbox.

Click OK when finished.
Hint: For a complete details for all of the items in the Addresses window, refer to the Add / Edit Message
Options section, page 164, in the Server Configuration Guide.
5.

Save the changes to the mailbox.
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Email Buttons
Once the feature has been enabled, incoming calls that are not answered will cause a button to be added to the subject
line in the email header of your client.
For calls where the contact leaves a voice message in the mailbox, a View button will appear beside the message.
If the caller did not get an answer and chose not leave a message, then the Dial button will appear.

Note: In the examples that follow, when initiating a telephone call to the contact, the device currently
selected is used. The current device is defined within your location setup. For example, if your current
location is Mobile, the call will ring on the device configured for that location (i.e. a cell phone). If you are In
Office, your desktop phone may be used instead.

Dial
The Dial button will start the iLink dialer and place a telephone call to the contact using the currently selected device.

View
Clicking the View button will open a window where the voice message in the inbox can be played back over any audio
enabled device. If licensed, the transcription of the message will also be included in the playback window.

Transcription license required
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Play
Choose Play to have the voice message converted to MP3 format and played through the browser.

Stream
Choose Stream when the browser player does not support the MP3 format, or if a different format is preferred.
The audio file will be played using an appropriate viewer, using the Voice Format specified in Messaging Admin on the
Mailbox > Message Options tab under Add/Edit.

Phone
Select this option to playback the message on the current default telephone device. The device will ring, and playback will
begin through the handset/speaker.

Google+ Hangout
Click on Google+ Hangout to create a video call in the default browser. Enter the contact’s name or number into the
space provided to start the event. Click Invite to send an invitation to join the hangout to the contact’s Google+ account.
The contact must be logged in to their account to receive the invitation.
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Google+ Share
Choosing Google+ Share allows the user to share the message with others through their Google+ account.

Enter a comment and the contacts to share the file with. Click Share when ready.

Twitter
The Tweet button allows the user to share the audio file with their Twitter followers.
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iLink Dialer
iLink Dialer opens a log displaying all calls made to and from the mailbox. Details include the caller’s extension or phone
number, the caller’s name, and the time, date and length of the call.
Click on a contact or their number to open their popup card. In window, click the contact’s number to place a call. Your
default telephone device will ring, and you will be connected to the contact.

iLink Messages
iLink Messages opens a list of voice messages left in the mailbox. Details include the name of the contact who left the
message, their number or extension, and the date and time the message was received.
Click on an item to playback the message.
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Contact Location
In various places through the window, moving the mouser over the contact’s name will open a new window which shows
their current location in Google Maps, if they have the Geo Location option enabled. There are also icons to contact them
through email or telephone.

Mail: Opens an email client program to compose and send an email message to the contact.
Call: Places a telephone call to the contact. Your desktop telephone will ring, and you will be connected with the
contact once they answer.
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Introduction
Note: Transcription provides text output from voice messages left in a user's mailbox. The user will
receive an email that contains the transcribed text.
The Transcription feature allows users to receive text output from voice messages. The transcribed voice message is
delivered to the user in the body of an email.
Transcription is not part of the standard Messaging license. It must be purchased separately. Licenses for Mutare
Transcription Services are available through Avaya.
This chapter describes the configuration for the Mutare on-premise transcription service. Mutare will provide the
necessary software to the client and assist with the installation and configuration.
Important: The transcription service is available only to accounts with Messaging and Collaboration (Avaya
Mainstream) Desktop Capabilities. An account with Messaging (Avaya Basic) alone will not have access to this
feature. Desktop Capabilities are configured in Messaging Admin on the Advanced tab for each mailbox.

Visual Guide
A voice message is
left on the
Messaging server.

Message is sent to the
Mutare server
across your network.

The voice message is
converted into text by
the Mutare on-prem
Transcription Service.

Text transcription of the voice
message is delivered as an
email with the voice message
included as an audio file
attachment.

The transcribed message is sent
back to the Messaging server.

When a voice message arrives on the voice server, the message is passed to the Mutare transcription server across the
corporate network. The message is then returned to the voice server once the transcription has been completed. The
voice and text messages are combined and delivered to the user’s mailbox.
Hint: Transcribing a voice message will take some time depending upon the length of the message and the
amount of traffic on the servers. If receiving a voice message immediately is critical for a user, it is
recommended either that transcription is turned off for that user, or that time out settings are configured to
ensure messages are delivered within an acceptable time limit.

Avaya Messaging Feature Description Guide

62

Mutare Transcription Service

Requirements

•
•

Requirements

Details

License

Mutare Subscription available from Avaya

Software

Officelinx version 10.6 - 10.7
Messaging version 10.8 or higher

Hardware

A computer that meets Mutare server requirements.

A Mutare transcription service subscription.
The Mutare software resides on the corporate network on its own machine. Ensure that a suitable computer is
available to host the transcription service.
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Licensing
The transcription feature is not included with the standard Messaging license but is available as an option from Avaya.
These instructions are only required if a Mutare transcription license is purchased after Messaging is installed and
configured.
Once you have purchased a license, it must be activated through the UC License Upgrade Utility. The service must then be
configured through the Transcription Configuration Tool.
Note: If this is a first time installation, and not an upgrade to an existing system, skip ahead to the Messaging
Server Configuration.

Upgrading the License
If Messaging has already been installed and setup on a server, add a transcription license by following these steps. If this
is a new installation, skip ahead to Messaging Server Configuration.
1.

On the Messaging server, go to Start > All Programs > Messaging > UCLicenseUpgrade.

2.

The License Upgrade Utility screen appears. Click Upgrade.
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3.

The Serial Number and Site ID will already be entered. If not, enter the data manually:
Serial Number: Enter the serial number for your Messaging license.
Site ID: Enter the site ID for your location.
Both of these items are provided by Avaya as part of the initial Messaging license package.

4.

Click Request Online Activation.

5.

The license will be updated from Avaya’s online license server to include the latest features.
Click Set as Active License. Click OK.

6.

Restart the server to complete the update.

Your transcription license is activated.
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Messaging Server Configuration
Messaging must be configured to communicate with the Mutare server over the corporate network. This applies
whether this is an upgrade or first time installation.
Note: The settings made here are system wide, applying to all accounts on all companies.

Transcription Configuration Tool
1.

On the Avaya Messaging voice server (in an HA installation, on the Primary and all Secondary voice servers), go to
Start > All Programs > Avaya Messaging > UCTranscriptionConfig.

2.

Enter all required information.

Save Voice Messages as Text: Enable to mark voice messages as text messages after transcription. Leaving this
unchecked will have the messages marked as voicemail in your mailbox once transcribed.
Transcribe Urgent Messages: Disable this checkbox to exclude messages flagged as Urgent from the
transcription service. Transcribing a message can take several minutes so this option allows urgent messages
to be delivered immediately without transcription.
Call Back URL: This is the externally (Cloud-based) or internally (On-premise) accessible URL of your Avaya
Messaging server (in an HA system, this will be the Primary Consolidated server) where Mutare will send
completed transcriptions. You can configure your DNS and change “YourCompanyDomain” only (i.e. from
“https://YourCompanyDomain/ucwebapi/api/1.0/user/transcriptions/mutare” you only need to change
“YourCompanyDomain”) since the virtual folders and the transcription receiver applications are automatically
setup.
Transcription AccountID: Enter the Mutare account information provided by your vendor.
Company Transcription APIKey: Enter the Mutare API key provided by your vendor.
Transcription Operator Type: Not applicable for a Mutare configuration.
Number of Minutes to hold... : Voice messages for selected mailboxes are put on hold until the transcription is
returned from the Mutare server. This value (in minutes) tells the system when to give up waiting for a
transcription and deliver the message as voice only. The default value is 15 minutes.
Transcription Provider URL: Enter the URL to reach Mutare on-prem server on the corporate network.
3.

Click Language Options. From the dropdown list, select a language / variation to use, then click OK.

Important: This field must not be left blank. There must be an language selected here.
4.

Click OK when finished.
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Verification
Once all of the information has been collected and the network adjustments made, the connection between the
customer’s network and the Mutare on-premise transcription server should be tested by sending a service request
through Messaging and waiting for the response. Any issues or unusual delays must be reported immediately so that the
situation can be resolved.

User Guide
When a new voice message is received:
1.

The system checks if the mailbox has transcription enabled.

2.

If so, it uses the UCTranscribeUploader service to submit the voice file for transcription. The Callback URL is also
sent to allow the Mutare server to reply with the results.

Note: The original message is put on hold for an amount of time defined by your administrator. The default
value is 15 minutes. This means that the UC system will send the message to the transcription service and
then wait for a maximum of 15 minutes for a response. If the message has not been returned in that time,
the process will time out and the untranscribed voice message will be sent to the mailbox. You should be
aware of the delay so that no problems arise from it.
3.

Once the transcription is complete, the Mutare server will use the Callback URL to return the results to the UC
system. The transcribed text will be the body of an email with the original voice message included as an audio
attachment.

4.

The combined message is delivered to the user’s mailbox.

Note: The maximum message length that can be transcribed is 60 seconds. The portion of the message
beyond 60 seconds will not be transcribed. The voice recording of the message will not be affected.
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Guidelines
Depending upon your site’s requirements and software, you have the option to integrate Avaya Messaging with several
email systems. None of these are required. Where appropriate, refer to the chapter that best suites your requirements.
CHAPTER

INTEGRATION

8

Google

9

Exchange using EWS

10

Exchange without EWS

11

Exchange 2010

12

Office 365 using Graph

13

Office 365 using EWS

WHY YOU WANT IT
Creates a secure connection through OAuth2 to your Gmail and
Google Apps accounts.
The simplest connection between your Exchange server and IXM.
A connection between Exchange and IXM for legacy systems.
A connection between Exchange 2010 and IXM.
Setup the latest high security integration procedures for maximum
data integrity.
Quick connection between your O365 server and IXM.

Introduction
Avaya Messaging transforms the way you handle online communications. With Messaging you can access voice and IM
communications, presence, click-to-call, location sharing and other communication tools inside the cloud applications
you work in regularly like Gmail, Google Calendar, and other Google Apps.
Avaya Messaging also offers:

•

Message Integration: Messaging can synchronize messages with Google Apps and Gmail servers, allowing users to
access a single endpoint to manage all of their messages. All of the user’s email, voice and fax messages can be
accessed through a single application through this integration. Users can listen to their Google email messages
through the phone and to their voice messages from the web by logging into their Google account. Message synch is
not bidirectional, so messages received directly in Google cannot be listened to in Messaging.

•

Contact & Calendar Integration: Messaging can synchronize contact entries and calendar events with your Google
Apps. Any entry that the user creates within Google will be automatically updated in Messaging. The reverse is also
true. Any entry that the user creates within Messaging will be automatically updated in Google.
Note: Repeating events in Google calendar, such as a weekly meeting, will only be synchronized with Avaya
Messaging out to 7 days ahead. Previewing beyond 7 days in advance will not show the recurring event in
the calendar.

By implementing these solutions, users gain access to many new features without substantially changing their work flow.
This allows for an increase in productivity without extensive retraining.
Avaya Messaging can also forward incoming messages (voice, email, fax) to a Google Drive location making all of your
communications available from anywhere in the world through the Internet.
Note: Integration with Google apps and other 3rd party applications and plug-ins may require additional
licensing.
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Synchronization Directions
Data synchronization between the Avaya Messaging servers and Google apps only occurs in the following directions.
ITEM SYNCHING

FROM

TO

Inbox

Messaging

Google

Google

Messaging

Contacts
Calendar

Messaging

Google

Google

Messaging

Messaging

Google

Implementation Example
IX Messaging Server

Google Apps Server

End user applications become
accessible through plug-ins.

Message, Contact and Calendar are
synchronized between the two
servers when integration is complete.

Requirements
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Details

License

---

Software

Officelinx version 9.1 - 10.7
Messaging version 10.8 and higher
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Server Configuration
Server configuration of Google Integration makes extensive use of CSE and CSE.PIM for message, contact and calendar
synchronization. As long as the web server is able communicate properly with the worldwide web, users will be able to
configure all of their gadgets and plug-ins on their own through the User Guide on page 90.
Client authentication and synchronization is handled using OAuth 2.0 and the Google API.

Install and configure OAuth2.0
OAuth 2.0 provides secure user authentication and is required for Gmail to access the messaging
servers.

OAuth 2.0 Setup
1.

Open a web browser and go to https://console.developers.google.com. Login using your Google credentials.

2.

Click the Navigation menu

3.

Click CREATE PROJECT.

Avaya Messaging Feature Description Guide

. Select IAM & Admin > Manage Resources.

72

Google Integration

4.

Give the new project a name, then click Create.

5.

Open the navigation menu and select IAM & Admin > IAM. Ensure that the project you just created is chosen in the
Select Project dropdown menu.

6.

In the left-hand panel, select Service accounts. Click CREATE SERVICE ACCOUNT.
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7.

Give the account a name and a description, then click CREATE AND CONTINUE.

8.

From the Select a role dropdown menu, choose Currently used > Owner. Click Continue then Done.
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9.

Click the name of the service account you just created.

10. Open the KEYS tab and click ADD KEY > Create new key. Enable the P12 option, and click CREATE.

11. The private key file will be created with a .p12 extension. Make note of where the file is saved (i.e. the Downloads
folder).
Copy the file to both the C:\UC\UCCSE and C:\UC\IMAPTSE folders.
(Change the path accordingly if your program is installed on a different drive.)
12. Record the Private key password (notasecret) and click CLOSE.
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13. Open the Navigation Menu and select APIs and services. Click OAuth consent screen.

14. Enable External, then click CREATE.
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15. Enter an App name for this configuration.
Provide a User support email address where users can find out more about their consent.
When ready, click SAVE AND CONTINUE.

16. From the Navigation menu, go to IAM & admin > Service accounts.
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17. For the account you just created, click the Actions icon and choose Manage Details.

18. Expand SHOW DOMAIN-WIDE DELEGATION and turn on Enable Google Workspace domain-wide delegation.
Enter a product name that will appear on the consent screen.
When ready, click Save.
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19. On this screen, record the Email address (for step 24) and the Client ID (for step 28).

Hint: You can drag the mouse over the Client ID value or the Email address, copy and paste the string into
Notepad. This helps to prevent copy errors.
20. From the Navigation
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21. Under the Google Workspace category, select Admin SDK API. You may need to click View all to see this item.
Click Enable.

22. Once enabled, return to the Google Workspace page (APIs & Services > Library).
Repeat to enable all of the following APIs:
●
●
●

Google Calendar API
Google Drive API
Gmail API

23. Return to the Library, selecting Social this time, then enable Contacts API.

Hint: While these settings will work for most sites, not all sites will want to open all of these channels if they
are not required. See Minimum Required Scopes and APIs by Product for details.
24. Rename both copies of the P12 file from step 11 to match the email address recorded in step 19.
Include the domain and the .com extension.

Caution: Do Not change the extension of the file. Always ensure it retains the P12 extension.
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Domain Setup
25. Go to admin.google.com and login to Google as an administrator.
In the left-hand panel, open Security > API controls.

26. Click MANAGE DOMAIN-WIDE DELEGATION.
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27. Click Add new.

28. In the space provided, enter the Client ID from step 19.

29. In the space for OAuth scopes, enter the following string:

https://docs.google.com/feeds/,https://mail.google.com/,https://
www.google.com/m8/feeds/,https://www.googleapis.com/auth/calendar

Hint: Copy and paste the string above into the field. This will greatly reduce the chance of misspelling the
entry and breaking the configuration.
Important: While these settings will work for most sites, not all sites will want to open all of these channels if
not required. See Minimum Required Scopes and APIs by Product for details.
30. When ready, click Authorise.
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31. Verify that the selected scopes were successfully installed.

The scopes are:
docs.google.com/feeds
mail.google.com
www.google.com/m8/feeds
www.googleapis.com/auth/calendar

OAuth2 and Messaging High Availability (HA)
When using OAuth2 in an HA environment, the private key must be copied to both of these locations on the
Consolidated server (C:\UC\IMAPTSE and C:\UC\UCCSE).
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Minimum Required Scopes and APIs by Product

SCOPES *
(see below)

auth/admin

AVAYA COMMUNICATOR FOR WEB

(CHROME EXTENSION)

AVAYA IX WORKSPACES

AVAYA CLOUD APPLICATION LINK

Enabling all of the listed scopes and APIs will work for most situations. However, not all administrators will want to open
all of these channels if it is not necessary. This table shows the minimum required scopes and APIs for each product.

•

•

•

•
•
•

•

•

•

•

•
•
•

•
•
•

auth/calendar
auth/drive
auth/drive.file
calendar/feeds
calendar/resource
m8/feeds
mail.google.com

APIs

Admin SDK
Contacts API
Google Calendar API
Google Drive API
GMail API

•
•
•
•
•
•
•

* The full paths for all listed scopes are displayed here.
auth/admin - https://www.googleapis.com/auth/admin.directory.user.readonly
auth/calendar - https://www.googleapis.com/auth/calendar
auth/drive - https://www.googleapis.com/auth/drive
auth/drive.file - https://www.googleapis.com/auth/drive.file
calendar/feeds - https://www.google.com/calendar/feeds/
calendar/resource - https://apps-apis.google.com/a/feeds/calendar/resource/
m8/feeds - https://www.google.com/m8/feeds/
mail.google.com - https://mail.google.com/
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Configuring Messaging for use with OAuth 2.0
Once OAuth 2.0 has been configured, Messaging must be setup to use it.
The following procedure is conducted on the Messaging Server.
32. Open IX Messaging Admin.
33. Right-click on TSE IMAP Server and select New > TSE IMAP Server.
IMAP Server Name: Enter Google in this space.
IMAP Server Address: Enter imap.gmail.com.
IMAP Server Port: Set this value to 993.
Voice Format: Leave this field unchanged.
Click OK when ready.
34. Click on Feature Group, and double-click a group to modify in the right-hand pane.
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35. Open the Synchronization Options tab. Enter values in the following fields:
IMAP Account: Enter your company domain, followed by a forward slash then the Email address from step 19.
For example, yourdomain.com/avaya-secure-connection@avayacloud....
Password and Confirm Password: Type in the Private Key password for the Client ID received in step 12.
IMAP Server: From the dropdown menu, select Google.

]

36. Synchronization Settings: Enable all of the items that you want to have synchronized between servers.
Calendar Mode: If calendar synchronization is required, select Synch with Mail Server Calendar from the
dropdown list.

37. Click Save

to preserve the changes.
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38. Go to the Mailbox Options tab and enable Change Location to allow an event in your mail server calendar to
automatically change the UC location of the user. If this feature is not required, leave it disabled.

Note: Repeating events in Google calendar, such as a weekly meeting, will only be synchronized with
Messaging out to 7 days ahead. Previewing beyond 7 days in advance will not show the recurring event in
the IXM calendar.
39. Click Save

to preserve the changes.

40. In IXM Admin, open Mailbox Structure and double-click a client to modify.
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41. Open the Synchronization Options tab. Set Storage Mode to Synchronization.

42. Enable the Use Feature Group settings for IMAP checkbox. For User Name, enter the Gmail address for this client.
davidi@erbmusic.com
janep@gmail.com
name@yourcompany.com

For example,

Note: Desktop Capabilities must be set to Advanced for these options to be configured.
43. Click Save

to preserve the changes.

44. Your Messaging mailbox will now synchronize contacts and/or
calendar information with the Gmail account.
Note: To make sure that your mailboxes are associated with the
right Feature Group check your Mailbox configuration window
under the General tab.
45. Repeat steps 40 through 43 for each client that requires OAuth 2.0
synchronization.
46. On the Voice Server, open the UC/UCCSE folder.
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47. Edit the CSE.exe.config file using any text editor (e.g. Notepad).
Locate the tag UseGMailAPI and set its value to True.

Go to File > Save to complete the change.
48. Stop and Start the UC Content Synchronization Engine and the UC CSE PIM Synchronization Engine services on
the Voice Server, or restart the server.
Caution: If this is a High Availability system, restart this services only on the Consolidated Server.

The setup is complete.
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User Guide
This user guide helps you configure your message, contact and calendar synchronization between Messaging and Google
Apps. While the installation and configuration related to these features are straight forward, please backup important
data before configuring any synchronization.

Message Synchronization
In order to consolidate all messages (e.g. voice, text, fax, etc.) in a single email account, synchronize your Gmail or Google
Apps email with the UC server’s Web Access mailbox. If your organization is using OAuth2 authorization, you will not
have to enter any details beyond the email address.
Note: If the synchronization does not work even after entering the correct credentials, your server may not
be configured properly for this feature. Please contact your system administrator.
Warning: If you have a custom filters configured on your Google account, it will not apply to messages that are
synchronized from the voice server (e.g. voicemail, fax, etc.).

Contact & Calendar Synchronization
When your administrator has enabled calendar and contact
synchronization for you, everything will be occurring on the server side in
the background so you do not have to configure anything on your own.
You can use your mail server as you normally would and your calendar
and/or contact entries will be populated on your Messaging mailbox as
well. The following are typical behaviors that the synchronization will
follow so that you can understand exactly how your calendar and contact
entries are being handled by the servers.
Note: When creating a calendar event from Google, you must ensure that the reminder time it set to
1 minute or greater. Setting this value to 0 will cause synchronization issues.
By default, the reminder time is 10 minutes.
Note: All your calendar events and contacts from your current mail server will be populated into your
Messaging mailbox right after your administrator finishes the configuration.
Note: You should backup your calendar events and contacts periodically as a precaution.
Note: Repeating events in Google calendar, such as a weekly meeting, will only be synchronized with
Messaging out to 7 days ahead. Previewing beyond 7 days in advance will not show the recurring event in
Google’s calendar.
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Contact Sync
When you create a contact entry through Gmail, the same entry will be synchronized into your Messaging contacts.

The contact information is automatically sent to
the Messaging contact list.

Warning: Keep in mind that deletions are also synchronized. If you delete an entry from Gmail, it will be
deleted from Messaging, and vice versa.
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Calendar Sync
When you create a calendar entry from Google Calendar, the same entry will appear in Messaging. The time and date of
the meeting is automatically sent to the Messaging mailbox. By default, the location for these events is marked as
Meeting, but this can be changed through the Web Access Calendar icon.

Manual Contact Importing
If synchronization is not an option for your site, you may manually copy contacts from one application to the other. Long
lists of contacts can be difficult to transfer. To make this process easier, Web Access supports importing CSV (comma
separated value) files that can be exported from Google Apps.
1.

To export your contacts from Google Apps, log into
your Google email account and open your Contacts
list.

2.

Click on More, then Export...
This opens the Export contacts window.

3.

You can choose to export selected contact, specific
groups of contacts (e.g. My Contacts), or all contacts.
Select All contacts.

4.

For export format, choose Outlook CSV.
Click on Export when ready.

5.

When prompted, specify the location where the file will be saved.

6.

With the CSV file ready, open Web Access and click
Contacts.
Click the Import button.
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7.

Click Choose File and select the CSV file exported from
Google.

8.

Click Next to proceed after the file has been selected.

Match the fields from the CSV file to the fields on the Web
Access contact list. You will only have to match the information you
require. Leave all the unnecessary fields as (disregard this field).
Click Import when all of the required fields have been matched.
The contacts will be imported from the CSV file into Web Access.
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Reconfiguring Synchronization Components for Gmail
Once the installation has been completed, verify that the system configuration files are set to use GMAIL. This should be
done on all servers running CSE: The voice server in a single server environment, the Consolidated server under HA, and
all remote CSE servers operating.
Note: The CSE.exe.config file is used with message synchronization, while the CSE.PIM.exe.config is used
for contact and calendar synchronization.

1.

Open the UC/UCCSE folder on the program installation drive.

2.

Within the folder, open the CSE.exe.config file in a text editor such as NotePad.
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3.

Scroll down to find the following lines (UseGMailAPI):
<setting name=”UseGMailAPI” serializeAs=“String”>
<value>True</value>
</setting>

Verify that the Value is set to True. If the value is not True, change it and save the file.
4.

Within the UCCSE folder, open the CSE.PIM.exe.config file in a text editor such as NotePad.
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5.

Scroll down to find the following lines (UseGMailAPI):
<setting name=”UseGMailAPI” serializeAs=“String”>
<value>True</value>
</setting>

Verify that the Value is set to True. If the value is not True, change it and save the file.

Restart Services
Before continuing, stop and restart the following services:
•
•

UC Content Synchronization Engine
UC CSE PIM Synchronization Engine

This will force Avaya Messaging to immediately update its systems. Otherwise, there will be a delay before the changes
become active.
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Guidelines
Depending upon your site’s requirements and software, you have the option to integrate Avaya Messaging with several
email systems. None of these are required. Where appropriate, refer to the chapter that best suites your requirements.
CHAPTER

INTEGRATION
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11

Exchange 2010

12

Office 365 using Graph

13

Office 365 using EWS
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WHY YOU WANT IT
Creates a secure connection through OAuth2 to your Gmail and
Google Apps accounts.
The simplest connection between your Exchange server and IXM.
A connection between Exchange and IXM for legacy systems.
A connection between Exchange 2010 and IXM.
Setup the latest high security integration procedures for maximum
data integrity.
Quick connection between your O365 server and IXM.
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Introduction
Avaya Messaging and an Exchange server are able to integrate through the IMAPCSE and Exchange Web Services (EWS),
providing a truly unified messaging experience. Once the configuration is complete the servers communicate and
synchronize all data among themselves, eliminating the need for you to constantly manage multiple locations.
Each user’s Exchange credentials are stored within the Messaging mailbox, allowing the server to synchronize messages
to and from the Exchange server. End users can manage their credentials through Web Access. Administrators may also
manage credentials from the admin console.
The use of EWS for Exchange 2019 and 2016 is required since IMAP is no longer supported. When using Exchange 2013,
the use of EWS is optional and follows the same procedures. This chapter may be applied to both versions.

Visual Guide

Data is synchronized between the Voice and Mail servers.
Message status and deletions are synchronized almost instantly
between the two, allowing a single message store for easier
management
administrators and end users.
anagement for both adm

You may also choose to synchronize
Contact and Calendar data between the
two servers along with messages.

In a typical situation, voice
synchronized
oice messages will be syn
from the Voice Server to the Mail Serve
Server.

Since status is synchronized,
message lights on integrated
telephone systems will also be
accurate no matter where the
message is read or received.

When a voice server integrates with an email server, the data between the two is synchronized, allowing for accurate
information regardless of the point of access. Receiving messages, and any actions performed by the users is
synchronized between the two servers constantly, ensuring that your content is always up-to-date.
Administrators can also customize what will be synchronized. A full synch includes contact and calendar entries along
with messages. If the system has telephone and message light integration, MWI (message waiting lights) will also remain
accurate since the status of messages are synchronized between the servers.

Requirements
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Requirements

Details

License

IMAPCSE License

Software

Messaging version 10.5 or higher
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Server Configuration
Server configuration requires the creation of a superuser account from the active directory that has the necessary
permissions within the Exchange console. Once the account has been made, it must be added to the voice server
configuration, and the channel of communication between the two servers must be established.
Your Exchange server must also have Exchange Web Services (EWS) enabled in order for Messaging to communicate
properly.
You must have a corporate Exchange server, either locally on virtually, configured and operating before proceeding.
Caution: Exchange 2019 and 2016 do not support non-EWS connections. Only EWS can be used.
Exchange 2013 supports both EWS and IMAP.

Exchange Superuser Creation/Configuration
Once the superuser account is ready on Active Directory, create a mailbox for that user in the Exchange environment.
1.

As an administrator, create a new user on your network using Active Directory. Configure any Organizational Units or
company policies as required. This user MUST have Password never expires enabled.

Avaya Messaging Feature Description Guide

100

Exchange 2019/2016/2013 Integration: Using EWS

2.

Open the Exchange admin center in a browser (e.g. https://IPaddressOfExchangeServer/ecp). Login with the
Exchange admin credentials. Go to the recipients menu at the mailboxes tab. Click New

3.

. Select User mailbox.

Enable Existing user. Click browse and select the user created in step 1. Provide a human friendly Alias to refer to
this user.

When ready, click Save.
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4.

In the left-hand panel, select permissions. Under the admin roles tab, click New

5.

Give the Role a name (a Description is optional). Beside Roles, click Add

6.

Select ApplicationImpersonation and click add ->. Click OK.
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7.

Below Members, click Add

8.

Returning to the new role group pane, click Save.

. Locate the account you just created, select it and click add ->. Click OK.

Confirm that the new role appears in the list.

The new account has been created.
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IXM Admin Configuration
For Messaging and Exchange to be able to synchronize data, Messaging must be able to communicate with the Exchange
server using the correct credentials. The superuser account streamlines this process while still enforcing individual
password security protocols on each mailbox.

Adding the CSE Endpoint for EWS
In order for the Messaging server to recognize the Exchange server, you must configure a CSE Endpoint entry in the IXM
Admin > TSE IMAP Server section to use the EWS server. A entry should already be present in IXM Admin based upon the
choice of email client you made during installation.
Note: TSE is the previous name for CSE services.
Double-click the server, or right-click and create a new one.

IMAP Server Name: This name is for your reference and does impact system performance.
IMAP Server Address: Enter the IP address of the EWS server. The address MUST be prefixed with ews: (all lower
case, with a colon).
IMAP Server Port: Set this to the port number of the EWS server. The default is 993.
Voice Format: Select the voice format used when sending voice messages to external voice servers.
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Feature Group Configuration
Once the TSE IMAP Server entry has been created, go to Feature Group > Synchronization Options and modify the
Office 365 user mailboxes as follows:
IMAP Account: Enter the user/service account created in step 3 above. Include the complete user@domain.com
(e.g. administrator@yourcompany.onmicrosoft.com).
Account / Confirm Password: Enter the super user/service account password from step 3.
IMAP Server: Type in the name of the IMAP TSE Server created in the previous step (e.g. OfficeMail365).
Calendar Mode: If calendar synchronization is required, select Sync with Mail Server Calendar from the
dropdown menu. Otherwise, select None.
Synchronization Settings: Set these options to specify which information will be synchronized between servers.

Save all changes.
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Individual Mailbox Configuration
With the superuser account, you do not have to enter the individual
mailbox credentials for CSE synchronization.
Enable Use Feature Group settings for IMAP then enter the
User Name in the format user@companydomain.com. Set the
Storage Mode to Synchronization.
Note: The user must be an Advanced user to utilize
synchronization.

Assign the mailbox to the Feature Group that is going to have the
superuser account credentials.
Save all changes and move onto Feature Group Configuration.
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Certificate Configuration
In order to ensure that the communication between Messaging and the Exchange server is not interrupted by security
measures, install the certificate from the Exchange server computer on the Messaging voice server. For a site using High
Availability, install the certificate on the Consolidated Server, and on all Remote CSE servers.
The simplest way to achieve this is to access the OWA (Outlook Web App) web page for Exchange on the voice server.
Note: This procedure may vary depending on the way in which you have the domain servers configured.
The goal of this process is to add the Exchange server as a trusted PC on the Messaging server
computer, which can be accomplished manually by the system administrator.
1.

Open the Internet Explorer web browser, then navigate to your company’s OWA web page
(e.g. https://111.222.1.0/owa).

2.

In the title bar, click the certificate error tab.

3.

Click View certificates.

4.

Click Install Certificate to launch to certificate wizard.

Caution: For all certificates, always ensure that you are on the proper web
page, and confirm the issuer of the certificate for security purposes before
proceeding with the installation.
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5.

Enable Current User and click Next.

6.

Enable Automatically select the certificate store based on the
type of certificate then click Next.

7.

Confirm that the information is correct, then click Finish.

8.

The following popup confirms the import was successful.
Click OK.
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9.

You will be able to confirm the status of the certificate through this window.

Note: Ensure that the domain server is also certified, not just the
Exchange server.

The certificate configuration is now complete. Restart the servers to ensure that
the services are properly initialized.
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Contact and Calendar Sync
Once you have configured the IMAP CSE server with your mail server, you will be able to select the degree of
synchronization from the Feature Group. Ensure that you verify all of the information so that users do not lose any
calendar, contact or message data during synchronization.
Warning: As a precaution, backup the calendar and/or contact events of your users before proceeding
with the contact and calendar synchronization.

Windows Configuration
The Superuser account must be configured as a local administrator on the voice server computer.
1.

In Windows, right-click the Start menu and choose Computer Management.

2.

Go to System Tools > Local Users and Groups > Groups. Double-click Administrators.
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3.

Ensure that the Superuser account created has the proper permissions on the Windows environment.

4.

The UC CSE PIM Synchronization Engine service must login and run with the Superuser credentials.
Open the Computer Management console and select Services.

5.

Right-click the service and select Properties.
Go to the Log On tab, and enable This Account.
Enter the username and password for the superuser account in the spaces provided.

Click Apply and OK when finished.
6.

Restart the service.

Avaya Messaging Feature Description Guide

111

Exchange 2019/2016/2013 Integration: Using EWS

Messaging Configuration - Feature Group
Feature Group configuration requires changes on two tabs; Synchronization Options and Mailbox Options. You can
define exactly what is going to be synchronized for the users from these two sections.
From the Synchronization Options tab, you can specify which
messages are going to be synchronized between the servers.
Enable Contacts if you wish to enable contact synchronization between
the two servers.
To enable calendar synchronization, select Sync with Mail Server from
the Calendar Mode dropdown menu.
The other fields, such as Inbox Folder, are used for message
synchronization between the servers. Refer to the message integration
section for details.

From the Mailbox Options tab, enable Change Location to allow an
event on the mail server calendar to automatically change the UC
location of the user.

By customizing these settings you can easily segregate calendar and contact synchronization along with message
synchronization when enabling features for your users, allowing you to control exactly who has access to certain
features.
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User Guide
Once calendar and contact synchronization has been enabled, all transactions occur on the server in the background, so
you do not have to configure anything on your own. Use your mail server as you normally would, and any calendar or
contact entries will now be mirrored in your Messaging mailbox as well.
The following is typical behavior for synchronization so that you can understand exactly how your calendar and contact
entries are being handled by the servers.
Note: All of the calendar events and contacts from your mail server will be copied into your Messaging
mailbox as soon as the administrator finishes configuring the systems.
Note: Backup your calendar events and contacts periodically as a precaution.

Calendar Synchronization
When you create a calendar entry in Outlook, or most other
email programs, the same entry will appear in your Messaging
mailbox.
The time and date of the meeting is automatically sent to the
Messaging mailbox. By default, the location for these events
will be marked as Meeting. You may change this manually
through Web Access, or in the case of Outlook, you may utilize
the iLink Pro Desktop tool bar to assign a specific location to
the event.

Contact Synchronization
When you create a contact entry from Outlook, the entry will be copied into your
Messaging mailbox.

Contact information is automatically sent to the Messaging mailbox.

Caution: Deleting contacts is also synchronized. If you delete an entry from Outlook, it will also be deleted
from Messaging, and vice versa.
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Synchronization Limits
When using EWS with Exchange, message synchronization is one-way only, from Avaya Messaging to Exchange. Any
messages created using Messaging will appear in Exchange, whereas messages created in Exchange will not appear in
Messaging.
Message synchronization can place a significant burden on the voice servers which can lead to delays. Changes may take
some time to be appear on the other side.

MS Exchange Performance Considerations
Be aware that large numbers of items in folders can decrease the speed of operations in Exchange. This table shows the
maximum number of files recommended per folder for optimum server performance.
Items in Folder

Exchange 2007

Exchange 2013

Exchange 2016

Messages

<20000

<100000

<100000

Contact and Calendar Entries

<5000

<10000

<10000
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Guidelines
Depending upon your site’s requirements and software, you have the option to integrate Avaya Messaging with several
email systems. None of these are required. Where appropriate, refer to the chapter that best suites your requirements.
CHAPTER

INTEGRATION
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Exchange using EWS

10

Exchange without EWS

11

Exchange 2010

12

Office 365 using Graph

13

Office 365 using EWS
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WHY YOU WANT IT
Creates a secure connection through OAuth2 to your Gmail and
Google Apps accounts.
The simplest connection between your Exchange server and IXM.
A connection between Exchange and IXM for legacy systems.
A connection between Exchange 2010 and IXM.
Setup the latest high security integration procedures for maximum
data integrity.
Quick connection between your O365 server and IXM.
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Introduction
Messaging and an Exchange server are able to integrate through the IMAPCSE services, providing a truly unified
messaging experience. Once the configuration is complete the servers communicate and synchronize all data among
themselves, eliminating the need for you to constantly manage multiple locations.
Each user’s Exchange credentials are stored within the Messaging mailbox, allowing the server to synchronize messages
to and from the Exchange server. End users can manage their credentials through Web Access. Administrators may also
manage credentials from the admin console.
Exchange 2013 can be configured for either IMAP or EWS integration. This chapter covers the setup required to use IMAP.
Caution: Exchange 2019 and 2016 do not support non-EWS connections. Only EWS can be used.

Visual Guide

Data is synchronized between the Voice and Mail servers.
Message status and deletions are synchronized almost instantly
between the two, allowing a single message store for easier
management
administrators and end users.
anagement for both adm

You may also choose to synchronize
Contact and Calendar data between the
two servers along with messages.

In a typical situation, voice
synchronized
oice messages will be syn
from the Voice Server to the Mail Serve
Server.

Since status is synchronized,
message lights on integrated
telephone systems will also be
accurate no matter where the
message is read or received.

When a voice server integrates with an email server, the data between the two is synchronized, allowing for accurate
information regardless of the point of access. Receiving messages, and any actions performed by the users is
synchronized between the two servers constantly, ensuring that your content is always up-to-date.
Administrators can also customize what will be synchronized. A full synch includes contact and calendar entries along
with messages. If the system has telephone and message light integration, MWI (message waiting lights) will also remain
accurate since the status of messages are synchronized between the servers.

Requirements

Avaya Messaging Feature Description Guide

Requirements

Details

License

IMAPCSE License

Software

Officelinx version 9.0 - 10.7
Messaging version 10.8 or higher
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Server Configuration
Server configuration requires the creation of a superuser account from the active directory that has the necessary
permissions within the Exchange console. Once the account has been made, it must be added to the voice server
configuration, and the channel of communication between the two servers must be established.
Exchange server must also have IMAP enabled in order for Messaging to communicate properly. Once the superuser
account is ready, enable IMAP for your Exchange server through the command shell.

Exchange 2013 superuser Creation/Configuration
Once the superuser account is ready on Active Directory, create a mailbox for that user in the Exchange environment.
1.

As an administrator, create a new user on your network using Active Directory. Configure any Organizational Units or
company policies as required. This user MUST have Password never expires enabled.
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2.

Open the Exchange admin center in a browser (e.g. https://IPaddressOfExchangeServer/ecp). Login with the
Exchange admin credentials. Go to the recipients menu at the mailboxes tab. Click New

3.

. Select User mailbox.

Enable Existing user. Click browse and select the user created in above. Provide a human friendly Alias to refer to
this user.

When ready, click Save.
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4.

On the mailbox features tab, ensure that IMAP and MAPI are both Enabled.

5.

At the Command Prompt, run the following command lines to attach the necessary permissions to the Superuser
account. Include the alias recorded earlier as a part of the command:
Get-Mailbox -OrganizationalUnit UnitName -ResultSize Unlimited | Add-MailboxPermission -User
ExchConnector -AccessRights FullAccess -InheritanceType All
Get-Mailbox -OrganizationalUnit UnitName -ResultSize Unlimited | Add-ADPermission -User ExchConnector ExtendedRights “Send As” -InheritanceType All
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6.

To verify the correct setup for the Superuser account, open any other account and go to the mailbox delegation
tab.
Ensure that the alias for the Superuser account is included beneath the listing for Full Access.

7.

From the Exchange 2013 Admin Center, go to Servers and open Exchange 2013.
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8.

Choose IMAP 4. Click More Options, and scroll down to find Maximum connections from a single user.
Set this value to 2000.
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9.

Open the Windows Server Manager MMC to view the system Services.
Set both of the IMAP4 services to use Automatic Startup.
If these services are still running, shut them down and restart them for the changes to take affect. Otherwise, Restart
both services.

10. The UC CSE PIM Synchronization Engine service must login and run with the Superuser credentials.
Open the Computer Management console and select Services.

11. Stop the UC CSE PIM Synchronization Engine service.
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12. Right-click the service and select Properties.
Go to the Log On tab, and enable This Account.
Enter the domainname\username and password for the superuser account in the spaces provided.

Click Apply and OK when finished.
13. Restart the service.
The new account has been created.
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IXM Admin Configuration
For Messaging and Exchange to be able to synchronize data, Messaging must be able to communicate with the Exchange
server using the correct credentials. The superuser account streamlines this process while still enforcing individual
password security protocols on each mailbox.

Adding the CSE Endpoint
In order for the Messaging server to recognize the Exchange server, you must add a new CSE
Endpoint entry in the IXM Admin > TSE IMAP Server section.
Note: CSE was formerly known as TSE.
IMAP Server Name: This name is for your reference and does impact system
performance.
IMAP Server Address: Enter the server address of the Exchange server.
IMAP Server Port: The port number of the Exchange server. By default, IMAP uses port 993.
Voice Format: From the dropdown menu, select the voice format used when sending voice messages to external
voice servers.

Individual Mailbox Configuration
With the superuser account, you do not have to fully enter the
individual mailbox credentials for IMAPCSE synchronization.
Enable Use Feature Group settings for IMAP then enter the
User Name (this will be the alias for the Exchange account that the
current mailbox will be synchronized with).
Under Storage Mode, select Synchronization.
Note: The user must be an Advanced user to employ
synchronization.

Assign the mailbox to the Feature Group that is going to have the
superuser account credentials.
Save all changes and move onto Feature Group Configuration.
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Feature Group Configuration
The Feature Group plays a key role in IMAPCSE synchronization by
providing the necessary credentials. From the Synchronization
Options tab, configure the settings as follows:
IMAP Account: Enter the user/service account created in step 3
above. Include the complete user@domain.com (e.g.
administrator@yourcompany.onmicrosoft.com).
Account / Confirm Password: Enter the super user/service
account password from step 3.
IMAP Server: Type in the name of the IMAP TSE Server created in
the previous step (e.g. OfficeMail365).
Calendar Mode: If calendar synchronization is required, select
Sync with Mail Server Calendar from the dropdown menu.
Otherwise, select None.
Synchronization Settings: Set these options to specify which
information will be synchronized between servers.
Save all changes and proceed to Registry Settings.
1.

Test the connection to verify the work this far. Launch the IMAP Tester utility from Start > Messaging.
Double-click on the Superuser account to open the IMAP Settings window.

2.

Click Verify to run the test.
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3.

If successful, the result will include the entry for OK LOGIN completed.

Registry Settings
In order for Messaging to manage communications with the Exchange server, you must
manually add a registry value on the Messaging server. Run the registry editor by typing
regedit from the Run command.
Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Generic\UMS\IMAPTSE\Cache.
Create a new DWORD Value entry in this location.

Name the entry DefaultExchangeVersion and assign it a value of 8.

The new registry entry will appear in the Registry.
Proceed with Certificate Configuration.
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Certificate Configuration
In order to ensure that the communication between Messaging and the Exchange server is not interrupted by security
measures, install the certificate from the Exchange server computer on the Messaging voice server. For a site using High
Availability, install the certificate on the Consolidated Server, and on all Remote CSE servers.
The simplest way to achieve this is to access the OWA (Outlook Web App) web page for Exchange on the voice server.
Note: This procedure may vary depending on the way in which you have the domain servers configured.
The goal of this process is to add the Exchange server as a trusted PC on the Messaging server
computer, which can be accomplished manually by the system administrator.
1.

Open the Internet Explorer web browser, then navigate to your company’s OWA web page
(e.g. https://111.222.1.0/owa).

2.

In the title bar, click the certificate error tab.

3.

Click View certificates.

4.

Click Install Certificate to launch to certificate wizard.

Caution: For all certificates, always ensure that you are on the proper web
page, and confirm the issuer of the certificate for security purposes before
proceeding with the installation.
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5.

Enable Current User and click Next.

6.

Enable Automatically select the certificate store based on the
type of certificate then click Next.

7.

Confirm that the information is correct, then click Finish.

8.

The following popup confirms the import was successful.
Click OK.
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9.

You will be able to confirm the status of the certificate through this window.

Note: Ensure that the domain server is also certified, not just the
Exchange server.

The certificate configuration is now complete. Restart the servers to ensure that
the services are properly initialized.

Avaya Messaging Feature Description Guide

130

Exchange 2013 Integration Non-EWS

Contact and Calendar Sync
Once you have configured the IMAP CSE server with your mail server, you will be able to select the degree of
synchronization from the Feature Group. Ensure that you verify all of the information so that users do not lose any
calendar, contact or message data during synchronization.
Warning: As a precaution, backup the calendar and/or contact events of your users before proceeding
with the contact and calendar synchronization.
Note: If you did not install the Exchange MAPI component during the initial Messaging installation, you
must do so manually now by running the ExchangeMapiCdo.msi file from MSExchange folder on
Messaging installation DVD. This is a required component for contact and calendar synchronization.

Windows Configuration
The Superuser account must be configured as a local administrator on the voice server computer. It must also be set to
run the UC TSE Cache Manager service.
1.

In Windows, right-click the Start menu and choose Computer Management.

2.

Go to System Tools > Local Users and Groups > Groups. Double-click Administrators.
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3.

Ensure that the Superuser account created has the proper permissions on the Windows environment.

4.

From Windows Server Manager > Services, double-click on the UC TSE Cache Manager service in the right-hand
pane.
On the Log On tab, enable the This account button and enter the credentials for the superuser account in the
spaces provided.
The typical format will be domain\super_user_name.
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Messaging Configuration - Feature Group
Feature Group configuration requires changes on two tabs; Synchronization Options and Mailbox Option. You can
define exactly what is going to be synchronized for the users from these two sections.
From the Synchronization Options tab, you can specify which
messages are going to be synchronized between the servers.
Enable Contacts if you wish to enable contact synchronization between
the two servers.
To enable calendar synchronization, select Mail Server from the
Calendar Mode dropdown menu.
The other fields, such as Inbox Folder, are used for message
synchronization between the servers. Refer to the message integration
section for details.

Mail Server

From the Mailbox Options tab, enable Change Location to allow an
event on the mail server calendar to automatically change the UC
location of the user.

By customizing these settings you can easily segregate calendar and contact synchronization along with message
synchronization when enabling features for your users, allowing you to control exactly who has access to certain
features.
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User Guide
Once calendar and contact synchronization has been enabled, all transactions occur on the server in the background, so
you do not have to configure anything on your own. Use your mail server as you normally would, and any calendar or
contact entries will now be mirrored in your Messaging mailbox as well.
The following is typical behavior for synchronization so that you can understand exactly how your calendar and contact
entries are being handled by the servers.
Note: All of the calendar events and contacts from your mail server will be copied into your Messaging
mailbox as soon as the administrator finishes configuring the systems.
Note: Backup your calendar events and contacts periodically as a precaution.

Calendar Synchronization
When you create a calendar entry in Outlook, or most other
email programs, the same entry will appear in your Messaging
mailbox.
The time and date of the meeting is automatically sent to the
Messaging mailbox. By default, the location for these events
will be marked as Meeting. You may change this manually
through Web Access, or in the case of Outlook, you may utilize
the iLink Pro Desktop tool bar to assign a specific location to
the event.

Contact Synchronization
When you create a contact entry from Outlook, the entry will be copied into your
Messaging mailbox.

Contact information is automatically sent to the Messaging mailbox.

Caution: Deleting contacts is also synchronized. If you delete an entry from Outlook, it will also be deleted
from Messaging, and vice versa.
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MS Exchange Performance Considerations
Microsoft (http://support.microsoft.com/kb/905803) advises that a large numbers of items in folders can decrease the
speed of operations in Exchange. This table shows the maximum number of files recommended per folder for optimum
server performance.
Items in Folder
Messages
Contact and Calendar Entries
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Exchange 2003
<5000 combined

Exchange 2007

Exchange 2003

<20000

<100000

<5000

<10000
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Reconfiguring Synchronization Components for IMAP
Once the installation has been completed, verify that the system configuration files are set to use IMAP. This should be
done on all servers running CSE: The voice server in a single server environment, the Consolidated server under HA, and
all remote CSE servers operating.
Note: The CSE.exe.config file is used with message synchronization, while the CSE.PIM.exe.config is used
for contact and calendar synchronization.

1.

Open the UC/UCCSE folder on the program installation drive.
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2.

Within the folder, open the CSE.exe.config file in a text editor such as NotePad.

3.

Scroll down to find the following lines (UseEWSIMAP):
<setting name=”UseEWSIMAP” serializeAs=“String”>
<value>True</value>
</setting>

Verify that the Value is set to True. If the value is not True, change it and save the file.
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4.

Within the UCCSE folder, open the CSE.PIM.exe.config file in a text editor such as NotePad.

5.

Scroll down to find the following lines (UseEWSGraph):
<setting name=”UseEWSIMAP” serializeAs=“String”>
<value>True</value>
</setting>

Verify that the Value is set to True. If the value is not True, change it and save the file.

Restart Services
Before continuing, stop and restart the following services:
•
•

UC Content Synchronization Engine
UC CSE PIM Synchronization Engine

This will force Avaya Messaging to immediately update its systems. Otherwise, there will be a delay before the changes
become active.
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Guidelines
Depending upon your site’s requirements and software, you have the option to integrate Avaya Messaging with several
email systems. None of these are required. Where appropriate, refer to the chapter that best suites your requirements.
CHAPTER

INTEGRATION

8

Google

9

Exchange using EWS

10

Exchange without EWS

11

Exchange 2010

12

Office 365 using Graph

13

Office 365 using EWS
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WHY YOU WANT IT
Creates a secure connection through OAuth2 to your Gmail and
Google Apps accounts.
The simplest connection between your Exchange server and IXM.
A connection between Exchange and IXM for legacy systems.
A connection between Exchange 2010 and IXM.
Setup the latest high security integration procedures for maximum
data integrity.
Quick connection between your O365 server and IXM.
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Introduction
Messaging and an Exchange server are able to integrate through the IMAPCSE services, providing a truly unified
messaging experience. Once the configuration is complete the servers communicate and synchronize all data among
themselves, eliminating the need for you to constantly manage multiple locations.
Each user’s Exchange credentials are stored within the Messaging mailbox, allowing the server to synchronize messages
to and from the Exchange server. End users can manage their credentials through Web Access. Administrators may also
manage credentials from the admin console.

Visual Guide

Data is synchronized between the Voice and Mail servers.
Message status and deletions are synchronized almost instantly
between the two, allowing a single message store for easier
management
administrators and end users.
anagement for both adm

You may also choose to synchronize
Contact and Calendar data between the
two servers along with messages.

In a typical situation, voice
synchronized
oice messages will be syn
from the Voice Server to the Mail Serve
Server.

Since status is synchronized,
message lights on integrated
telephone systems will also be
accurate no matter where the
message is read or received.

When a voice server integrates with an email server, the data between the two is synchronized, allowing for accurate
information regardless of the point of access. Receiving messages, and any actions performed by the users is
synchronized between the two servers constantly, ensuring that your content is always up-to-date.
Administrators can also customize what will be synchronized. A full synch includes contact and calendar entries along
with messages. If the system has telephone and message light integration, MWI (message waiting lights) will also remain
accurate since the status of messages are synchronized between the servers.

Requirements
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Requirements

Details

License

IMAPCSE License

Software

Officelinx version 8.5 - 10.7
Messaging version 10.8 or higher
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Server Configuration
Server configuration requires the creation of a superuser account from the active directory that has the necessary
permissions within the Exchange console. Once the account has been made, it must be added to the voice server
configuration, and the channel of communication between the two servers must be established.
Exchange server must also have IMAP enabled in order for Messaging to communicate properly. Once the superuser
account is ready, enable IMAP for your Exchange server through the command shell.

Creating a superuser from Active Directory
A new user account must be created before it can be setup as a superuser with the necessary access privileges.
1.

From the active directory, create a new user.
The user name can be anything.
For this guide, we will be using “super_user” as the user name and
“perf.local” as the domain within which Exchange 2010 is installed.

Note: Change the domain and user name to match your network’s
requirements.

2.

Ensure that Password never expires is enabled.
Since this password is applied to the Feature Group, an expired password
means that all mailbox accounts associated with that Feature Group will
not be synchronized until the password is reset.

3.

Confirm the information then click Finish to add the user.
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4.

After the user is created, ensure that it is a member of a group with the
necessary access.
The correct group to join may vary from system to system, but the key is to
ensure that this user has full administrative access to the Exchange server.

Proceed to the Exchange 2010 configuration after the superuser account is ready.
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Exchange 2010 superuser Creation/Configuration
Once the superuser account is ready on Active Directory, create a mailbox for that user in the Exchange 2010
environment.
1.

Create a new User Mailbox mailbox from the
Exchange 2010 Management Console.

2.

When prompted, choose Existing User.

3.

Click on the Add button.
In the popup window, select the superuser account that
was previously in the Active Directory.
Click OK to add that account to the list of new mailboxes.

4.

Click Next to continue.
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5.

Select the correct database and change any other settings
that are required by your system configuration.

6.

Confirm the information then click New to create the
mailbox.

7.

The superuser account has been created.
Click Finish to exit the wizard.
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8.

In order for a superuser account to
properly manage all messages, you must
allow a higher number of connections
than there are by default.
Open the IMAP4 Properties from the
Client Access section.

9.

From the Connection tab, set
Maximum connections from a single user to 1000.

10. From the Retrieval Settings tab, set Message MIME format to Text.
Click OK to save your changes.
Now that the superuser account is ready, prepare the Exchange 2010 server for
integration and apply the correct administrative rights to the superuser
account.
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11. The UC CSE PIM Synchronization Engine service must login and run with the Superuser credentials.
Open the Computer Management console and select Services.

12. Stop the UC CSE PIM Synchronization Engine service.
13. Right-click the service and select Properties.
Go to the Log On tab, and enable This Account.
Enter the username and password for the superuser account in the spaces provided.

Click Apply and OK when finished.
14. Restart the service.
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Exchange 2010 Shell Configuration
Since only simple actions are available through the GUI, continue the configuration through the Exchange Management
Shell.

Note: <> represents a single space in the command.

Configuring the IMAP server
All IMAP server settings may be viewed by typing the command:
Get-imapsettings
For integration with the IMAPCSE, you must execute this command to change the way in which logins are handled by
IMAP.
Set-imapsettings<>–logintype<>PlaintextLogin
By default, the IMAP server daemon is disabled in Exchange 2010, so you must turn it on manually. You must configure
the server so that the IMAP services are always started automatically for server restarts.
Set-service<>msExchangeIMAP4<>–startuptype<>automatic

Start the IMAP Service
Start–service<>msExchangeIMAP4
At this stage, the IMAP service will be running, and it will start each time the computer restarts.
To test this, open a command prompt (Windows prompt not Exchange Shell) and enter telnet<>serverIP<>143. You
should see the banner reply. You may also verify the procedure by checking the status of the service.
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IMAP Enabling All Existing Mailboxes in a Store
If the mailboxes within your Exchange server do not have IMAP enabled, you
can use the following commands to enable the feature for the mailboxes. You
may confirm the status of the feature by opening the mailbox properties, then
going to the Mailbox Features tab as shown here.
Note: All mailbox accounts that require IMAPCSE synchronization must
have IMAP enabled under Exchange.

IMAP Enabling All Users
Get-mailbox<>|<>Set-CASMailbox<>–ImapEnabled:$true
This command gets each mailbox and pipes it into the Set-CASMailbox
command sequentially.

IMAP Enabling a Single User
Use this command to individually enable IMAP on each user.
Set-CASMailbox<>%mailbox%<>–ImapEnabled:$true
The %mailbox% variable represents the mailbox account name for which you want to enable IMAP.

Configuring Permissions for the superuser Account
The following commands will give the superuser account permission to logon to all user’s mailboxes. There are two
separate commands needed; type the first, hit enter, and then type the second.
In both cases, the %superuser% variable represents the domain and superuser account you have created in the
previous steps. For example, if the superuser’s user name is SUPER_USER, and the domain is COMAPNY.COM, enter
COMPANY\SUPER_USER in place of %superuser%.

Command 1
Get-Mailbox<>|<>Add-ADPermission<>-User<>'%superuser%'<>-ExtendedRights<>'Send-as'<>-InheritanceType<>All

Command 2
Get-Mailbox<>|<>Add-MailboxPermission<>-User '%superuser%'<>-AccessRights<>'FullAccess'<>-InheritanceType<>All
This is the last configuration step required on the Exchange 2010 server and you are ready to move on to the Messaging
configuration.
Note: If you add new mailbox accounts to the Exchange server after this point, you must enable those
accounts for IMAP manually as well. To do this, use the following commands.
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IMAP Enable a New Mailbox
Set-CASMailbox<>%mailbox%<>–ImapEnabled:$true

Run a Modified Version of Command 2 Without the Pipeswitch
add-mailboxpermission<>-identity%mailbox%<>-User '%superuser%'<>-AccessRights<>'FullAccess'<>InheritanceType<>All
You can confirm the access rights for the superuser account
by opening the Manage Full Access Permission panel. The
superuser account name should be listed.

A More Secure Solution
Command 1 and 2 (above) provide full access for the superuser to the entire store drive. Instead, you can use these
commands to limit access to just the MSExchange stores:

Get-MailboxDatabase | Add-ADPermission -User '%superuser%' -AccessRights ExtendedRight ExtendedRights Receive-As, ms-Exch-Store-Admin
Note: If a new mailbox database is created for Microsoft Exchange, you must re-enter this command so
that the new file is given the correct user access rights.
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Messaging Admin Configuration
For Messaging and Exchange to be able to synchronize data, Messaging must be able to communicate with the Exchange
server using the correct credentials. The superuser account streamlines this process while still enforcing individual
password security protocols on each mailbox.

Adding the CSE Endpoint
In order for the Messaging server to recognize the Exchange server, you must add a new CSE
Endpoint entry in the Messaging Admin > TSE IMAP Server section.
Note: CSE was formerly known as TSE.
IMAP Server Name: This name is for your reference and does impact system
performance.
IMAP Server Address: Enter the server address of the Exchange server.
IMAP Server Port: The port number of the Exchange server. By default, IMAP uses port 993.
Voice Format: From the dropdown menu, select the voice format used when sending voice messages to external
voice servers.
IMAP Server Domain: Enter the Domain address of the IMAP server. Since it is possible to define the IMAP Server
Address using an IP address, the Domain address entered here is used to verify the Reply to address of a mailbox
using IMAP CSE synchronization, preventing typical message looping scenarios.

Individual Mailbox Configuration
With the superuser account, you do not have to fully enter the
individual mailbox credentials for IMAPCSE synchronization.
Enable Use Feature Group settings for IMAP then enter the
User Name (this will be the alias for the Exchange account that the
current mailbox will be synchronized with) and leave the User
Password and IMAP Server fields empty.



Note: The user must be an Advanced user to employ
synchronization.
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Assign the mailbox to the Feature Group that is going to have the
superuser account credentials.
Save all changes and move onto Feature Group Configuration.

Feature Group Configuration
The Feature Group plays a key role in IMAPCSE synchronization by
providing the necessary credentials. From the Synchronization
Options tab, configure the settings as follows:
IMAP Account: Enter the account name for the superuser. The
typical format will be domain/super_user_name.
Account Password: Enter the password of the superuser account.
Confirm Password: Re-enter the password.

PERF/super_user
********
********
Exchange

IMAP Server: Select the CSE Endpoint created in the previous steps.
Save all changes and proceed to Registry Settings.
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Registry Settings
In order for Messaging to manage communications with the Exchange server, you must
manually add a registry value on the Messaging server. Run the registry editor by typing
regedit from the Run command.
Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Generic\UMS\IMAPTSE\Cache.
Create a new DWORD Value entry in this location.

Name the entry DefaultExchangeVersion and assign it a value of 8.

The new registry entry will appear in the Registry.
Proceed with Certificate Configuration.
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Certificate Configuration
In order to ensure that the communication between Messaging and the Exchange server is not interrupted by security
measures, install the certificate from the Exchange server computer on the Messaging server.
The simplest way to achieve this is to access the OWA (Outlook Web Access) web page of the Exchange server.
Note: This procedure may vary depending on the way in which you have the domain servers configured.
The goal of this process is to add the Exchange server as a trusted PC on the Messaging server
computer, which can be accomplished manually by the system administrator.
1.

Open the Internet Explorer web browser, then navigate to the OWA page
(e.g. https://exchange_2010/owa).
You will see the following security warning popup.
Click on View Certificate.

2.

Click on Install Certificate to launch to certificate wizard.

Caution: For all certificates, always ensure that you are on the proper web
page, and confirm the issuer of the certificate for security purposes before
proceeding with the installation.

3.

Click Next.
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4.

Enable Automatically select the certificate store based on the
type of certificate then click Next.

5.

Confirm that the information is correct, then click Finish.

6.

The following popup confirms the import was successful.
Click OK.

7.

You will be able to confirm the status of the certificate through this window.

Note: Ensure that the domain server is also certified, not just the
Exchange server.

8.

Depending on the security settings on the system, you may
also see the following warning popup.
Click Yes to accept the certificate in this case.

The certificate configuration is now complete. Restart the
servers to ensure that the services are properly initialized.

Avaya Messaging Feature Description Guide

155

Exchange 2010 Integration

Contact and Calendar Sync
Once you have configured the IMAP CSE server with your mail server, you will be able to select the degree of
synchronization from the Feature Group. Ensure that you verify all of the information so that users do not lose any
calendar, contact or message data during synchronization.
Warning: As a precaution, backup the calendar and/or contact events of your users before proceeding
with the contact and calendar synchronization.
Note: If you did not install the Exchange MAPI component during the initial Messaging installation, you
must do so manually now by running the ExchangeMapiCdo.msi file from MSExchange folder on
Messaging installation DVD. This is a required component for contact and calendar synchronization.
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Feature Group
Feature Group configuration requires changes on two tabs; Synchronization Options and Mailbox Option. You can
define exactly what is going to be synchronized for the users from these two sections.
From the Synchronization Options tab, you can specify which
messages are going to be synchronized between the servers.
Enable Contacts if you wish to enable contact synchronization between
the two servers.
To enable calendar synchronization, select Mail Server from the
Calendar Mode dropdown menu.
The other fields, such as Inbox Folder, are used for message
synchronization between the servers. Refer to the message integration
section for details.

Mail Server

From the Mailbox Options tab, enable Change Location to allow an
event on the mail server calendar to automatically change the UC
location of the user.

By customizing these settings you can easily segregate calendar and contact synchronization along with message
synchronization when enabling features for your users, allowing you to control exactly who has access to certain
features.
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User Guide
Once calendar and contact synchronization has been enabled, all transactions occur on the server in the background, so
you do not have to configure anything on your own. Use your mail server as you normally would, and any calendar or
contact entries will now be mirrored in your Messaging mailbox as well.
The following is typical behavior for synchronization so that you can understand exactly how your calendar and contact
entries are being handled by the servers.
Note: All of the calendar events and contacts from your mail server will be copied into your Messaging
mailbox as soon as the administrator finishes configuring the systems.
Note: Backup your calendar events and contacts periodically as a precaution.

Calendar Synchronization
When you create a calendar entry in Outlook, or most other
email programs, the same entry will appear in your Messaging
mailbox.
The time and date of the meeting is automatically sent to the
Messaging mailbox. By default, the location for these events will
be marked as Meeting. You may change this manually through
Web Access, or in the case of Outlook, you may utilize the iLink
Pro Desktop tool bar to assign a specific location to the event.

Contact Synchronization
When you create a contact entry from Outlook, the entry will be copied into your
Messaging mailbox.

Contact information is automatically sent to the Messaging mailbox.

Caution: Deleting contacts is also synchronized. If you delete an entry from Outlook, it will also be deleted
from Messaging, and vice versa.
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MS Exchange Performance Considerations
Microsoft (http://support.microsoft.com/kb/905803) advises that a large numbers of items in folders can decrease the
speed of operations in Exchange. This table shows the maximum number of files recommended per folder for optimum
server performance.
Items in Folder
Messages
Contact and Calendar Entries
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Exchange 2007

Exchange 2003

<20000

<100000

<5000

<10000
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Guidelines
Depending upon your site’s requirements and software, you have the option to integrate Avaya Messaging with several
email systems. None of these are required. Where appropriate, refer to the chapter that best suites your requirements.
CHAPTER

INTEGRATION

8

Google

9

Exchange using EWS

10

Exchange without EWS

11

Exchange 2010

12

Office 365 using Graph

13

Office 365 using EWS

WHY YOU WANT IT
Creates a secure connection through OAuth2 to your Gmail and
Google Apps accounts.
The simplest connection between your Exchange server and IXM.
A connection between Exchange and IXM for legacy systems.
A connection between Exchange 2010 and IXM.
Setup the latest high security integration procedures for maximum
data integrity.
Quick connection between your O365 server and IXM.

Introduction
This configuration note describes the implementation of unified messaging between Office 365 and Avaya’s Messaging
using Microsoft Graph as an alternative for Microsoft’s Exchange Web Services.
Warning: The instructions found in this guide cannot be guaranteed to work for all installations since each site
is unique. Some problems may arise even if you follow these instructions precisely. Therefore, use this
document as a reference for your own configuration, making the changes appropriate to your site's specific
requirements.
Note: This document describes the standard configuration for the integration of Avaya Messaging with
Microsoft Office 365. For a high security connection, such as for sites requiring JITC compliance, please
contact your vendor to purchase Professional Services support.

Pre-requisites
The following preliminary steps must be completed before the integration can begin:

•

The Office 365 domain has been setup and deployed (requires Mid-size Business and Enterprise plan minimum, E1
or E3).

•
•

You must have administrative access to the Office 365 domain.
Messaging Server installed and running (refer to Avaya’s documentation web site).
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Connecting Through Microsoft Graph
As an option, Messaging can be connected to Office 365 using Microsoft Graph. This adds an additional layer of security
to your communication traffic flows.
Warning: This section contains advanced concepts and programming steps that could adversely affect
operations if handled incorrectly. Read through these instruction thoroughly before proceeding. If you are
not confident to follow these instructions adequately, do not continue.

1.

Open a web browser and go to the Office 365 site at https://www.office.com.
Click Sign in and login using your Office 365 administrator account credentials.

2.

Click Admin.
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3.

In the left-hand panel (Show All), under Admin centers, select Azure Active Directory. The Azure dashboard will
appear.

4.

Open Azure Active Directory and select App registrations.
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5.

Click New registration.

6.

Provide a name for the registration. Enable Accounts in this organizational directory only. A redirect URI is not
required. Click Register.

7.

Record the value for Application (client) ID. This will become part of the username when configuring Feature Group
access within Messaging.
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8.

To configure the permissions for the application, click API permissions > Add a permission.

9.

Under Microsft APIs, select Microsoft Graph.

10. Choose Application permissions.
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11. Under Application Permissions, enable:
•
•
•
•
•

Calendars.ReadWrite
Contacts.ReadWrite
Mail.Read
Mail.ReadWrite
Mail.Send
Click Add permissions.

Note: The permissions that are required are based upon each site’s requirements. For example, if
Calendar or Contact synchronization is not necessary, then those permissions can be left out.
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12. Click Add a permission.

13. Under Microsft APIs, scroll down and select Azure Active Directory Graph.

14. Choose Delegated permissions.
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15. Under Delegated permissions, enable:
•

User.Read
Click Add permissions.

16. Wait 10 seconds, then click Grant admin consent for... . When prompted to confirm consent, click Yes.
If prompted to sign-in, provide the username and password.
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17. Ensure that all of the Status indicators are green for the permissions you just added. If not, delete them and start
again.

18. Open Certificates & secrets and select New client secret.

Avaya Messaging Feature Description Guide

170

Office 365 Integration with Microsoft Graph

19. Give the Secret a meaningful description. Choose when the Secret should expire (1 year, 2 years, or never).
When ready, click Add.

{

}

Important: Once a Secret expires, synchronization will no longer function until a new Secret is created.
20. Record the Value associated with the Secret. This is the password required when configuring the Feature Group in
Messaging.

21. In Messaging Admin, add a new TSE IMAP server, and include the Office 365 server information.
IMAP Server Name: Enter a name for this connection (e.g. OfficeMail365).
IMAP Server Address: Type in ews:outlook.office365.com.
IMAP Server Port: Set to 993 to enable SSL connectivity.
Voice Format: Select MPEG-1 Audio Layer 3 (MP3) for client playback.
Click OK when ready.

22. Go to the Feature Group > Synchronization Options tab.
Under IMAP Settings, configure:
•

IMAP Account: Enter your corporate Office 365 domain name, a forward slash, then the Application (client) ID
recorded in step 7.
(e.g. yourcompany.com/ab12cde3-45f6-789a-bc0d-1234ef567890).

•

Account / Confirm Password: Enter the Client Secret Value recorded in step 20.
(e.g. :]Ab=c1dEfGhijKlmno?pQRS2tUv3WX4)
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•
•
•

IMAP Server: From the dropdown menu, select Office 365.
Synchronization Settings: Enable all of the items that you want to have synchronized between servers.
Calendar Mode: If calendar synchronization is required, select Sync with Mail Server Calendar from the
dropdown menu. Otherwise, select None.

Note: The settings for the Office 365 connection through Graph can only be made to Feature Groups.
These settings cannot be made at the mailbox level.
The configuration is complete.
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Reconfiguring Synchronization Components for Graph
Once the installation has been completed, modify the system configuration files to use EWS instead of IMAP. This should
be done on all servers running CSE: The voice server in a single server environment, the Consolidated server under HA,
and all remote CSE servers operating.
Note: The CSE.exe.config file is used with message synchronization, while the CSE.PIM.exe.config is used
for contact and calendar synchronization.

1.

Open the UC/UCCSE folder on the program installation drive.

2.

Within the folder, open the CSE.exe.config file in a text editor such as NotePad.
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3.

Scroll down to find the following lines (UseEWSGraph):
<setting name=”UseEWSGraph” serializeAs=“String”>
<value>False</value>
</setting>

Verify that the Value is set to True. If the value is not True, change it and save the file.
<setting name=”UseEWSGraph” serializeAs=“String”>
<value>True</value>
</setting>
4.

Within the UCCSE folder, open the CSE.PIM.exe.config file in a text editor such as NotePad.
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5.

Scroll down to find the following lines (UseEWSGraph):
<setting name=”UseEWSGraph” serializeAs=“String”>
<value>False</value>
</setting>

Verify that the Value is set to True. If the value is not True, change it and save the file.
<setting name=”UseEWSGraph” serializeAs=“String”>
<value>True</value>
</setting>

Restart Services
Before continuing, stop and restart the following services:
•
•

UC Content Synchronization Engine
UC CSE PIM Synchronization Engine

This will force Avaya Messaging to immediately update its systems. Otherwise, there will be a delay before the changes
become active.

Note After Upgrading or Updating
Whenever Avaya Messaging is updated from an earlier version, it is important to check the settings configured above.
During the update, these values will be overwritten with the default program settings.
Repeat the steps given above to configure the software for use with MS Graph.
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Guidelines
Depending upon your site’s requirements and software, you have the option to integrate Avaya Messaging with several
email systems. None of these are required. Where appropriate, refer to the chapter that best suites your requirements.
CHAPTER

INTEGRATION

8

Google

9

Exchange using EWS

10

Exchange without EWS

11

Exchange 2010

12

Office 365 using Graph

13

Office 365 using EWS

WHY YOU WANT IT
Creates a secure connection through OAuth2 to your Gmail and
Google Apps accounts.
The simplest connection between your Exchange server and IXM.
A connection between Exchange and IXM for legacy systems.
A connection between Exchange 2010 and IXM.
Setup the latest high security integration procedures for maximum
data integrity.
Quick connection between your O365 server and IXM.

Introduction
This configuration note describes the implementation of unified messaging between Office 365 and Avaya’s Messaging.
Warning: The instructions found in this guide cannot be guaranteed to work for all installations since each site
is unique. Some problems may arise even if you follow these instructions precisely. Therefore, use this
document as a reference for your own configuration, making the changes appropriate to your site's specific
requirements.
Note: This document describes the standard configuration for the integration of Avaya Messaging with
Microsoft Office 365. For a high security connection, such as for sites requiring JITC compliance, please
contact your vendor to purchase Professional Services support.

Pre-requisites
The following preliminary steps must be completed before the integration can begin:

•

The Office 365 domain has been setup and deployed (requires Midsize Business and Enterprise plan minimum, E1 or
E3).

•

Messaging Server installed and running (refer to Avaya’s documentation web site), either in a single server
configuration, or in a High Availability environment (1 Consolidated server, 1 Primary server, 1+ Secondary servers).
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Office 365 Configuration
Web Interface Configuration
1.

Log into the Office 365 Administration interface through a web browser at https://login.microsoftonline.com/ or
similar as setup by your administrator.
Click Admin.

2.

Under User Management, select Add User.
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3.

Enter a first and last name, display name, the username and password for the superuser (service) account.
Click Next.
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4.

Set the user’s geographic location on the dropdown list. Under Assign a Product License, select Office 365 E3.
When ready, click Next.

Note: A license must be available on your system for you add this user. If all licenses are already in use,
delete one, or purchase additional licenses for this user.
5.

Make no changes here, and click Next.
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6.

Review the user settings. If everything is correct, click Finish adding.
If some elements need to change, click the Edit link beneath the incorrect item.

7.

The user has been created. Click Close.
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8.

In the left-hand panel (Show All), under Admin centers, select All Admin Centers.
From the list of applications, click Exchange.

9.

Select Permissions in the left-hand pane. Click New
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10. Give the Role a name (a Description is optional). Beside Roles, click Add

.

11. Select ApplicationImpersonation and click add ->. Click OK.

12. Below Members, click Add
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13. Returning to the new role group pane, click Save.

14. Confirm that the new role appears in the list.

The new account has been created.
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Avaya Messaging Server
Server Configuration
1.

In Messaging Admin, add a new TSE IMAP server, and include the Office 365 server information.
IMAP Server Name: Enter a name for this connection (e.g. OfficeMail365).
IMAP Server Address: Type in ews:outlook.office365.com.
IMAP Server Port: Set to 993 to enable SSL connectivity.
Voice Format: Select MPEG-1 Audio Layer 3 (MP3) for client playback.
Click OK when ready.

2.

Once the TSE IMAP Server entry has been created, go to Feature Group > Synchronization Options and modify the
Office 365 user mailboxes as follows:
IMAP Account: Enter the user/service account created in step 3 above. Include the complete
user@domain.com (e.g. administrator@yourcompany.onmicrosoft.com).
Account / Confirm Password: Enter the super user/service account password from step 3.
IMAP Server: Type in the name of the IMAP TSE Server created in the previous step (e.g. OfficeMail365).
Calendar Mode: If calendar synchronization is required, select Sync with Mail Server Calendar from the
dropdown menu. Otherwise, select None.
Synchronization Settings: Set these options to specify which information will be synchronized between
servers.
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3.

Ensure that individual mailboxes are configured under Mailbox > Synchronization Options with their User Name
(e.g. test1@here.yourdomain.com), and that Use Feature Group settings for IMAP is enabled Set Storage Mode to
Synchronization.
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Connecting Through EWS Using OAuth 2.0
As an option, Messaging can be connected to Office 365 using Exchange Web Services. This can add an additional layer of
security to your communication traffic flows. This section is not required.
Warning: This section contains advanced concepts and programming steps that could adversely affect
operations if handled incorrectly. Read through these instruction thoroughly before proceeding. If you are
not confident to follow these instructions adequately, do not continue.
Note: You must have corporate Office 365 and EWS accounts for this configuration.
Important: These instructions require a certificate for securing the connections. It is Strongly advised that
you purchase a certificate from an Certification Authority (CA) instead of using self-signed certificates. Both
a Public Key and a Private Key certificate file are required.

1.

Open a web browser and go to the Office 365 site at https://www.office.com.
Click Sign in and login using your Office 365 administrator account credentials.

2.

Click Admin.
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3.

In the left-hand panel, open Admin centers (Show all) and select Azure Active Directory. The Azure dashboard will
appear.

4.

Click Azure Active Directory > App registrations.
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5.

Click New registration.

6.

Provide a name for the registration. Enable Accounts in this organizational directory only. No redirect URI is
required. Click Register.

7.

To configure the permissions for the application, click API permissions > Add a permission.
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8.

Under Select an API, go to the APIs my organization uses tab.

9.

Find and select Office 365 Exchange Online.

10. Click Application permissions.

11. Enable full_access_as_app. Click Add permissions.
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12. Wait 2-5 minutes for the updates to propagate through the system, then click Grant admin consent for... .

13. If the configuration was a success, a pop-up will appear in the upper right corner of the window.

14. From the Office 365 dashboard, open Azure Active Directory > App registrations. Click the application just
created.

15. Copy the Application (client) ID.

16. You will have received 2 certificate files from the Certifying Authority: one is a Public Key, the other is a Private key.
Rename the Private key. Change the extension to .p12. Replace the name of the file with the Application (client) ID
value recorded in step 15.
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For example:

0a987b654cd32.pfx ----> 12a34bc5-67de-890f-12a3-4b56c7de89f0.p12

Copy this file into both the UC/UCCSE and the UC/IMAPTSE folders on the IX Messaging voice server. For a site
using High Availability, copy the file to the same folders on the Consolidated Server, and on all Remote CSE servers.
Rename the Public key. Change the extension to .cer .
For example:

2a345678bc906d78.pfx ----> 2a345678bc906d78.cer

17. Click Certificates & secrets in the left-hand pane. Select Upload certificate.

18. Click Browse
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19. Open UC Admin on the Voice Server. Go to the Feature Group > Synchronization Options tab.
Under IMAP Settings, configure:
IMAP Account: Enter your corporate Office 365 domain, a forward slash, then the Application (client) ID.
(e.g. yourcompanydomain.com/12a34bc5-67de-890f-12a3-4b56c7de89f0).
Account / Confirm Password: Type in the password used to secure the .p12 certificate file.
IMAP Server: Enter the name of your IMAP server.

When ready, click Save.
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20. In UC Admin, open Mailbox Structure. Open a person’s mailbox that will use this configuration. Go to the
Synchronization Options tab.
Enable Use Feature Group settings for IMAP.
Type in the User Name for this account.
For Storage Mode, select Synchronization.

When ready, click Save.

The configuration is complete.
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Verify Configuration Setting
Once the installation has been completed, verify that the system is configured to use EWS instead of IMAP.
1.

On a Single Server Installation, open the UC/UCCSE folder on the program installation drive.
For HA installations, this file is found on the Consolidated server in the same folder.

2.

Within the folder, open the CSE.exe.config file in a text editor such as NotePad.
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3.

Scroll down to find the following lines:
<setting name=”UseEWSIMAP” serializeAs=“String”>
<value>False</value>
</setting>

Verify that the Value is set to False. If the value is not False, retype the text and save the file to change it to the
correct value.
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Introduction
Messaging and a IBM Domino server are able to integrate through the IMAPCSE services, providing a truly unified
messaging experience. Once the configuration is complete the servers communicate and synchronize all data among
themselves, eliminating the need for you to constantly manage multiple locations.
The use of the administrator account from IBM Domino allows you to streamline the sign on process while still
maintaining individual password security protocols on each mailbox. The Domino administrator account credentials are
entered through the Messaging Admin console.

Visual Guide

Data is synchronized between the UC Server and the Mail Server.
Message status and deletions are synchronized almost instantly
between the two, creating a single message store for easier
management by both the administrators and end users.
Since status is synchronized,
message lights on integrated
telephone systems will also be
accurate no matter where the
message is read or received.

In a typical situation, voice messages will be synchronized from the
Voice Server to the eMail Server, and email messages will be
synchronized from the eMail Server to the Voice Server.

When a voice server integrates with an email server, the data between the two is synchronized, allowing for accurate
information regardless of the point of access. Receiving messages, and any actions performed by the users is
synchronized between the two servers constantly, ensuring that your content is always up-to-date.
Administrators can also customize what will be synchronized. A full synch includes contact and calendar entries along
with messages. If the system has telephone and message light integration, MWI (message waiting lights) will also remain
accurate since the status of messages are synchronized between the servers.

Requirements
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License

IMAPCSE License

Software

Officelinx version 8.5 - 10.7
Messaging version 10.8 or higher
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Server Configuration
IBM Domino configuration is largely divided into two parts. First is the configuration of both the Domino server and the
Messaging server to synchronize messages between the mailboxes on both systems. Second is configuring UC forms for
IBM Notes so that end users will have the ability to record and playback voice messages from their IBM Notes client.
While specific variables regarding settings will differ from site to site, this guide provides a general guideline for
integrating IBM Domino with Messaging.

Setting up IMAP CSE Synchronization
To configure IBM Notes for Messaging users:
1.

Access the IBM Notes Administrator.

2.

Under the Domain/People directory, double click User and enter a nickname, a user name and an Internet password.

3.

On the IBM Domino Console, run the following command:
Load Convert –m mail\username.nsf * ucmail.ntf.

Note: In the above command, username is the IBM mail file, and ucmail.ntf is the template into which the
forms were installed.
Note: Once the forms have been installed and distributed to the users, their inbox will need to be closed
and reopened in order for the templates to be refreshed. This needs to be done every time the Master
Template is updated.
The following procedure is optional.

To prevent the IBM Window from scrolling while logging in / out in IMAP:
1.

On the IBM Notes Server, open the notes.ini file.

2.

Set the Log_Session=1 to 0.

3.

Click Save, then click Close.
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Messaging Configuration: Single User
Note: Configuring Messaging for use with Superuser credentials is no longer supported.
With this option, Messaging connects to the IBM Domino server on a mailbox-by-mailbox basis, using each individual
client’s account credentials for each connection.
It is necessary to establish IMAP CSE connections before setting up Unified Messaging.
To begin the setup of your unified messaging you need to create a CSE IMAP connection. The purpose of this connection
is to tell the voicemail what IP address it is supposed to connect to in order to connect to your IBM Domino server.

To create CSE IMAP connections
1.

Login to Messaging Admin. The following screen appears.

2.

Locate TSE IMAP Server in the left-hand pane. Right-click and select
New > TSE IMAP Server. The following screen appears.

3.

Complete the following fields:
•
•

In the IMAP Server Name text field, enter a descriptive name of the server.
In the IMAP Server Address text field, enter the Domino server’s IP address.

Note: If you are using an SSL connection, you should use the server’s domain name
(DNS) instead of the IP address so that the certificate can be authenticated properly.
SSL connections should always use port 993.
•
•
•

Accept the default value in the IMAP Server Port field or enter the server port field provided to you by your
network Admin.
Select the Voice Format that your servers will use to handle voice messages.
In the IMAP Server Domain field, enter the domain name of the mail server to avoid looping messages during
synchronization. This server address will be cross referenced with the Reply To address of each mailbox.

Note: CSE was formerly known as TSE.
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Setting Up Unified Messaging (UM)
Mailbox integration is a configuration where each individual user on your Domino server is given their own mailbox on
the Messaging system.
1.

Obtain the list of the users you are going to integrate.

Hint: Contact your system administrator to verify that the
usernames and passwords are correct before proceeding.
2.

On the voice server machine, open Messaging Admin.

3.

Open the Mailbox properties.

4.

On the Addresses tab, verify that the Reply To email address is the
address of the user’s IBM Domino account. Click Save.

5.

Click on the Advanced tab.

6.

From the Desktop Capabilities dropdown list, select
Messaging & Collab.

7.

Click the Save Mailbox toolbar button.

Warning: The following steps must be completed in the specified
order.
8.

Click on the Synchronization Options tab.

9.

In the User Name field, enter the details of the user’s IBM Domino
email account. Change all forward slashes / to pipes |, such as:
Firstname Lastname|Organizationname

Note: Organizationname may include the domain and other
information. Separate all fields by a pipe instead of a slash.
any body|ERB|Music|Sales

10. From the Storage Mode dropdown list, select IMAP.
11. Enter the mailbox Internet password in the User Password and
Confirm Password fields.
12. For IMAP Server, select the Domino server.
13. Disable the Use Feature Group setting for IMAP checkbox.
14. In the IMAP Language field, choose the language of the mailbox. You must make a choice in this field.
15. Do not use the Message Status feature. Make sure that the Update Message Status From checkbox is not checked.
16. Click on the Save Mailbox toolbar button.
17. On the voice server machine, open IMAP Tester.
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18. Click on IMAP Synchronization Settings.
19. Click on the Performance/Tuning tab.
20. Disable the High Performance Pack checkbox.
21. Click Apply to save the changes. Exit the utility.
22. Restart the UC TSE Cache Manager service.
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Installing UC Forms for IBM Notes
This section describes the installation and configuration of UC forms for IBM clients. UC forms components are packaged
in the UCMail.ntf IBM template database, which can be found on the installation DVD. The UCMail template contains the
following:

•
•
•

UC Player subform that can be used to extend other forms with an audio player/recorder.
A subform to indicate the location of iLink Pro Desktop installation file.
Modified versions of Memo, Reply, and Reply with History forms with UC Player subform added to each.

There are two methods for installing UC forms onto the server:

•
•

A - Use a provided template as the basis for all UC users.
B - Copy design elements from a provided templates into another, and modify standard forms to include the UC
Player subform. This method allows you to add UC player to existing custom templates.

Regardless of which method is used, the design is made available to the IBM Notes client through a manual design
refresh initiated by the client, or by running the designer task on the server. Once the design elements are propagated to
the target database, each user is provided with an install button within IBM Notes that allows the installation of binary
components on the client PC.

Using the Provided Template as Design (Method A)
1.

Insert the Messaging Installation DVD.

2.

Copy the ucmail.ntf from the DVD (located inside IBM folder) and paste it into the Domino Data folder
(e.g. C:\Program Files\IBM\IBM\Domino\Data).

3.

When you open Domino Administrator, you will notice UC Mail in the list of available templates. Select the template
then open it in the Domino Designer.
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4.

Expand Shared Elements > Subforms in the left pane of the Designer window. From the main pane locate UCPlayer
and double click to open.

5.

The fields associated with the UC Player subform appear. Open the UCIBMSRV variable and enter the Messaging
server’s domain name or IP address. This is where end users download the iLink Pro Desktop application. When
ready, Save and Close the subform. This will update the design element signer.

Hint: Use the UCIBMVer field to manage version control with UC form.
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6.

From the Forms section, double click on Memo. Save and close the Memo form to update the design element signer.

7.

Repeat the process for Reply form. Open the form then Save and close to update the design element signer.

8.

Repeat the process for Reply with history form. Open the form then Save and close to update the design element
signer.

9.

Repeat the process for any other forms you wish to add the UC Player to, and then exit Domino Designer.
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ECL Configuration
IBM Domino uses an Execution Control List (ECL) to set up workstation data security. An ECL limits the actions of
formulae, scripts, forms and other objects run on a workstation. For example, an ECL can prevent another person's code
from running on a PC and damaging or erasing data.
Domino administrators have the power to allow users to modify their ECLs or to control all changes to their ECLs across
an organization. In order to limit workstation access, an ECL will look for a database, template and item signature before
opening on the workstation. The ECL will then check this signature against its settings to determine what level of access
can be granted.
Groupware forms are subject to an ECL check as well, since they contain scripts and COM objects. Thus, on the first
installation of Groupware forms within an organization, you are advised to:
•
•

Modify the Administrative ECL on the Domino Server.
Propagate the changes to all clients.

1.

Open Domino Administrator. Locate the People & Groups tab.
From Actions menu, select Edit Administration ECL.

2.

From the Workstation Security: Execution Control List window, click on the Add button.

3.

In the People, Servers, or Groups field, enter the name of the person/server/group to be added to the ECL. This
should be the person that performed the installation, most likely the Domino Administrator.
Once you have selected a user, click OK.
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4.

Now select the user or object added in the previous step (Administrator in this example). Enable Allow user to
modify, then select the Workstation security radio button. Enable all checkboxes under Allow then click OK.

5.

Repeat for both the Java applet security and JavaScript security radio buttons.

6.

For each mailbox database that will include UC forms, configure them to inherit the design from the UCMail
template. This can be done using the load convert command, or manually through mailbox database properties.

7.

Now that the forms are ready, you must append the new design. From Status > Server Tasks, click Start... in the list
of tasks on the right pane.
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8.

Select Designer from the list then click Start Task. The design will be updated for all
Users. Users can now take advantage of the forms packaged with iLink Pro Desktop in
IBM Notes.

Note: Once the design elements have been propagated to the client database, the
forms are almost complete. A few additional components must be installed to fully
enable forms on the client.
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Adding UC Forms to Existing Design (Method B)
1.

This procedure is similar to Method A, but you will be importing the UC form into an existing database template so
that you can utilize UC form within an existing custom form design. Please refer to the details within Method A to
familiarize with yourself with the procedure before proceeding.

2.

Insert the Installation DVD.

3.

Copy the ucmail.ntf from the DVD and paste into the Domino Data folder
(e.g. C:\Program Files\IBM\IBM\Domino\Data).

4.

Navigate to File > Database > Open. Select the ucmail.ntf file from Step 3 and open it in Domino Designer.

5.

Open the copied template. This template should contain the UC forms. As a rule, all users in an organization will
inherit design elements from a single template. Should it be necessary to provide UC functionality to a select group of
users, it is recommended that a copy of the default template be created and all UC elements placed there. Design
elements for UC user databases can then be inherited from the created template.

6.

Edit the UCIBMSRV variable to point to your Web Access for iLink Pro Desktop download.

7.

Copy the UCPlayer subform and paste it into the target template. If the UCPlayer subform is already present in the
target template (upgrade scenario), then remove it prior to upgrading.

8.

Open the Memo form in the target template and select Create > Resource > Insert Subform.

9.

Click OK. The UCPlayer subform will be inserted into the Message form.

10. Click Save and close the form.
11. Repeat Steps 7-10 for each form that is to include the UCPlayer subform.
12. Create three copies of the modified Memo form and give them the following names: TelNTVoice, TelNTFax, and
TelNTText.
13. Follow the procedures on ECL Configuration on page 208 to complete the process.
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User Guide
Installing UC Forms in IBM Notes
To use UC forms within IBM Notes, you must install iLink Pro Desktop. Obtain iPD from IBM Notes.

Installing UC Bar and iLink Pro Desktop
Note: Subforms must be inserted in all areas which require voice message playback function.
1.

Run IBM Notes.

2.

Open the mail database.

3.

Create or open a document that uses a form with the UC Player subform (e.g. Memo).

4.

In the Actions pane click on the Install UC bar button.

5.

IBM Notes will open a web page to download the iLink Pro Desktop software. iPD must be installed for UC forms to
work.

6.

Download the installation package then install the application.

7.

Once iLink Pro Desktop is installed, the button will change to Show UC bar. Click on this button to open the UC form.

Note: You may have to restart IBM Notes or reopen a form in order to see the new button. You must also
be logged into iLink Pro Desktop to use the UC forms.
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8.

You will now have access to Record and Playback actions through the form.

Verifying the IBM Notes client ECL setup
1.

Open IBM Notes.

2.

Select File > Security > User Security > What Others Do > Using Workstation. The User Security dialog box
appears.

3.

The ECL should contain all of the entries that were defined in the Administration ECL.
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Using UC Forms in IBM Notes
Composing a Voice Message
1.

Create a new message.

2.

Fill out the To, Subject and any other fields as you would normally do.

3.

Use the UC bar provided to record a message.

•

Click

to begin recording the voice message with your microphone.

•

Click

to begin recording the voice message with your phone.

•

Click

to pause recording or playback.

•

Click

to stop recording or playback.

•

Click

to playback recorded message.

Note: Some actions may not be available depending on site settings.
4.

When you finish recording a message, you will see an attachment automatically created as shown.
Click Send to transmit your message.
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Listening to a Voice Message
1.

Open a voice message from IBM Notes. UC forms will detect voice messages and provide options for message
playback.

•

Click

•

Click

•

Click

to begin playing the voice message on your PC speaker.
to begin playing the voice message on your phone.
to pause playback.

•Click

to stop playback.

Note: Some actions may not be available depending on site settings.
2.

If you choose to play the message on your phone, you will be given an option to choose which number to listen from.
The list depends on your current UC location and the extensions defined through iLink Pro Desktop. When you select
a number to listen from, UC server will dial that number, then playback the message once the call is answered.
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Configuring UC Mailbox to Synchronize with IBM Notes
Note: If you do not have access to Web Access, this configuration can be performed by your administrator.
1.

Log into Web Access.

2.

Click on the Account icon.

3.

If the Locked checkbox is selected, deselect this checkbox.

4.

Provide the following information:
User Name: Enter your mail server user name.

Note: The user name you enter in this field will be the same user name for the email account as it exists on
the mail server.
Password: Enter the password for your mail account.
Note: The password you enter in this field will be the same password for the email account as it exists on
the mail server.
Confirm Password: Confirm the above password.
Voice Format: From the dropdown menu, select the voice format which will be used for voice messages. You
should leave this field as default in most cases.
5.

Click on Save and Close button at the top.
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Introduction
Find me Follow me allows calls to be forwarded to one or more
addresses until the user is found. The addresses can be internal or
external numbers. They can be dialed sequentially, or simultaneously.
This document is intended for technicians who have some familiarity
with the Messaging and want a deeper understanding of what is
expected of the functions and how to set up users.
The Find Me Follow Me features for DID and direct calls are only
available for some PBX’s. In the case of Iwatsu ECS, the stations need to
be monitored with the CTI Link, and the calls need to be forwarded to
the UC Locations options in the feature group.
Refer to the Technical Operating Guidelines for details on PBX’s.
Note: The Hunt Group field should be left bank.

Visual Guide

A callertriesto reacha
user thr
ough UC Server.

UC Server tries ot locate the user yb trying all
devices simultaneously
. Whenthe useranswers
the phone, otherdevices will stop ringing.

If the user has configured Find Me Follow Me for their mailbox, Messaging will try to locate the user through a broadcast
rather than through a single phone number or device. Whenever a call comes in, Messaging will try to locate the user
through multiple devices simultaneously (or as configured). Once the user accepts the call on one device, Messaging will
connect the caller with the user and terminate the other calls.

Requirements
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Details

License

---

Software

Officelinx version 8.5 - 10.7
Messaging version 10.8 or higher

218

Find me Follow me on CTI Integration

User Guide
This guide goes over the configuration of Find me Follow using Web Access. If you have access to the admin console, this
process can be completed from there as well.

Find me Follow me with CTI Integration
Note: Before users can launch Web Access, two items must be set in Messaging Admin:
1) Enable Web Access User under Mailbox > Advanced, and
2) Select Web Access under Feature Group > Mailbox Options.
If you do not have access to the Messaging Admin console, please contact your System Administrator.
When you log into Web Access, the Main page will appear. Click Locations.

The locations page shows all the locations created for the user. From this page, the user can create a new location or edit
an existing location. Click on the location to be configured, then open the Find Me Rules tab.

The Find Me Rules page displays all of the options available for that location. It is important to note that this section will
configure how the Auto attendant will behave for incoming calls. However, it is necessary to set the current location as
well as availability. Refer to page 240 of the Client Applications Guide for further details on these settings.
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Addresses
Addresses are an important part of the find me follow me feature, and are necessary when configuring the locations
where the program will call the user. Addresses in this context refer to internal and external phone numbers where calls
will be directed based on the rules and configuration selected.
It is important to first define the addresses or numbers where the user can be reached for various locations in order to
configure the find me follow me features.
Addresses can be added, edited and deleted on the Addresses page of Web Access. Addresses can be internal (such as a
desk phone extension) or external (such as a cell phone or phone number off site).

To set your current location using Web Access, click on the Current Location icon.
Enable Override my locations calendar and set my current location. Set your location and availability from the
dropdown menus.

In order for outside calls to be dialed by the voice server, configure outcalling through
Windows Control Panel > Phone and Modem Options and make sure the local area code is selected.
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If the call will be forwarded to a long distance number, enable Long Distance under
Feature Group > Notification Options > Outcalling Options for the group containing the member.
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Configuring Find me Follow me features
There are several pre-defined options for the Auto attendant to automatically find a user by forwarding calls to a range of
numbers, either internal or external. Click on the Find me rules tab and select a rule and option:

Only call me at the first number assigned to this location
Select the option Only call me at the first number assigned to this location and then click on the General tab to
go back to the list of numbers assigned to the location.

Using the up and down arrows
the list.

, select the number you want calls to be forwarded to and move it to the top of

Click on the Save and Close button
The Auto Attendant will call only the number on top of the list of numbers assigned to that specific location. If there
is no answer at that extension, the Auto attendant will play the location greeting configured. We can expect this
behavior when calls are made to a DID or through the Auto attendant.
Note: In order for this feature to work, the user must be set up to be in that location and Available. If the
user is Unavailable the find me follow me feature will be disabled and the Auto attendant will play the
location greeting.
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Call me at each of the numbers assigned to this location sequentially
This rule gives the user 2 options: Automatically find me and Ask the caller to find me.

Automatically find me:
On the Find Me Rules tab, select the appropriate options and then go to the General tab to arrange the sequence of calls:

On the General tab, add the addresses to the Numbers assigned to this location column and using the up/down arrows
select the sequence in which you want to be found (from top to bottom).

Note: In order for this feature to work, it is necessary to have at least 2 addresses in this column, otherwise
there is no sequence and the find me feature will not be in effect
Click on the Save and Close button
When a call is transferred by the Auto attendant or when a call is made to a DID that rings the extension directly, the Auto
attendant will dial all the addresses in the list of numbers assigned to the location sequentially from top to bottom until
the call is answered, if there is no answer in any of the numbers the call will be forwarded to the user’s voicemail.
If the default internal address of that mailbox is in the list of numbers assigned to the location, calls made to a DID will
always ring that extension first regardless of where it is in the list, and then the Auto attendant will dial the rest of the
numbers in sequence from top to bottom (bypassing the default internal extension)
Note: In order for this feature to work, the user must be set up to be in that location and Available. If the
user is Unavailable the find me follow me feature will be disabled and the Auto attendant will play the
location greeting. Also, if the phone is in DND, the unavailable greeting will automatically play and the find
me feature will not come in effect.
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Ask the caller to find me:
This feature will play the unavailable prompt and then give the caller the option to locate the user or just leave a
message.
On the Find Me Rules tab, select the appropriate options and then go to the General tab to arrange the sequence of calls:

On the General tab, add the addresses to the Numbers assigned to this location column and using the up/down arrows
select the sequence in which you want to be found (from top to bottom).

Note: In order for this feature to work, it is necessary to have at least 2 addresses in this column, otherwise
there is no sequence and the find me feature will not be in effect
Click on the Save and Close button
When a call is transferred by the Auto attendant or when a call is made to a DID that rings the extension directly, the Auto
attendant will automatically dial the first address in the list of numbers assigned to the location, if there is no answer it
will play a “no answer” and give the caller the option to locate the user or to leave a message. If the caller selects to locate
the user the Auto attendant will dial the next number in the list, if there is no answer in any of the numbers the call will be
forwarded to the user’s voicemail.
If the default internal address of that mailbox is in the list of numbers assigned to the location, calls made to a DID will
always ring that extension first regardless of where it is in the list, and then the Auto attendant will dial the rest of the
numbers in sequence from top to bottom (bypassing the default internal extension)
Note: In order for this feature to work, the user must be set up to be in that location and Available. If the
user is Unavailable the find me follow me feature will be disabled and the Auto attendant will play the
location greeting. Also, if the phone is in DND, the unavailable greeting will automatically play and the find
me feature will not be in effect.
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Call me at all the numbers assigned to this
location at the same time
When using this Find me rule, the Auto attendant will try to find the user at
all of the numbers assigned to the location at the same time, either
automatically or by giving the caller the option to locate the user. The caller
will also be given the option to leave a message.
When this feature is selected it is necessary to specify the channels used for
the broadcast in Company Properties > C.O./Channel Assignment.

3-5

3-5

Automatically find me:
On the Find me rules tab, select the Call me at all the numbers assigned to this location at the same time and the
Automatically find me options, and then go to the General tab to choose the numbers the Auto attendant will dial:

On the General tab, in the right-hand column add the numbers that the Auto attendant will dial when trying to find the
user.

Click on the Save and Close button
When a call is transferred by the Auto attendant or when a call is made to a DID that rings the extension directly, the Auto
attendant will automatically dial all the addresses in the list of numbers assigned to the location simultaneously. If the
call is answered and accepted in one of those numbers the calls made to the other numbers in the list will be dropped. If
there is no answer in any of the numbers the call will be transferred to voicemail.
When a call is made to a DID and the default internal extension is in the list of numbers assigned to the location, that
internal extension will always ring first and if there is no answer then the Auto attendant will automatically dial the rest of
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the numbers in the list simultaneously.
Note: In order for this feature to work, the user must be set up to be in that location and Available. If the
user is Unavailable the find me follow me feature will be disabled and the Auto attendant will play the
location greeting. Also, if the phone is in DND, the unavailable greeting will automatically play and the find
me feature will not come in effect.

Ask the caller to find me:
On the Find me rules tab, select the Call me at all the numbers assigned to this location at the same time and Ask
the caller to find me options, and then go to the General tab to choose the numbers the Auto attendant will dial:

On the General tab, in the right hand column add the numbers that the Auto attendant will dial when trying to find the
user:

Click on the Save and Close button.
When a call is transferred by the Auto attendant, the first number in the list will be dialed, and if there is no answer the
caller will be given the option to locate the user or leave a message. If the caller decides to locate the user, the Auto
attendant will dial the rest of the numbers in the list simultaneously until one of the numbers answers and accepts the
call. If the call is answered and accepted in one of the rest of the numbers, the calls made to the other addresses in the
list will be dropped. If there is no answer in any of the numbers the call will be transferred to voicemail.
When a call is made to a DID we should expect the same behavior as above as long as the default internal extension is
not on the list of numbers assigned to the location. If the default internal extension is in the list of numbers assigned to
the location, that internal extension will always ring first (regardless of the order in the list) and if there is no answer in
the internal extension, the caller will be given the option to locate the user or leave a message.
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Introduction
Avaya’s Messaging has built in mail capabilities, including Unified Messaging integrated to multiple mail environments.
Since many of our customers have implemented the Avaya’s Messaging as a centralized messaging platform, it is
desirable to offer users who access Avaya’s mail components to be presented their messages in their time zone.
The following document outlines the steps to configure the UC Server to use this functionality.

Visual Guide

IX Messaging Server

User Location
User Location

When the users are location in a diﬀerent time
zone from the IX Messaging server, the server is able
to honor the time zone of the user and display the
date and time of the message dynamically.

When you configure the multiple time zone support feature for your users, they will be able to access their messages
anywhere around the world and see the messages in relation to local time rather than the server’s time. This will reduce
any confusion over when the message was received and offer the users a care-free user experience.

Requirements
Requirements

Details

License

---

Software

Officelinx version 8.5 - 10.7
Messaging version 10.8 or higher

Important: In an HA installation, all servers must have the same time zone set under Windows Date / Time
settings. If the servers are configured for different time zones, the timestamps will not play correctly.
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Server Configuration
With Messaging installed on the server, you will need to edit the EEAM.INI file, located in the WINDOWS folder of your
system.

General Settings
1.

Go to Start > RUN, and type EEAM.INI in the space provided.
Click OK.
NotePad will open and display the contents of the file.

2.

Add the following line to the EEAM.INI file:
Honor Timezone for Message = 1

3.

Save the file, and close the editor. RESTART the PC for the change to take
effect.

Your system is now ready to manage multiple time zones.

Caution: In order to specify your time zone, you will need to edit your Location Calendar. Each time you access
your mailbox, either through the phone, the web or any other component, your CURRENT time zone will be
determined by your active location calendar. Make sure this is specified.
Note: If the user does not have access to Web Access to specify their location calendar, an Administrator
will need to set this using Messaging Admin.

The Time Zone feature supports:
•
•
•

All Messages presented via any device will be in the user’s local time.
Call History will be presented in the user’s local time.
Calendar events made using Outlook will be retained in the user’s local time as defined by their Location Calendar.
For example, if the user’s PC where Outlook is running is set for Eastern time, but the Location Calendar is defined as
Pacific, then any appointment created by the client from Outlook will be offset from Eastern time to Pacific, as
specified by the user’s Location Calendar.

The Time Zone feature does NOT support the following:
•

Notification schedules – any schedule defined must be defined in the Server’s time. For this reason, Web Access will
now show the server’s time in a window to assist the user.

•
•
•

Future message delivery – message delivery must be defined in the Server’s time.
Wakeup Call – All events must be defined in the Server’s time.
Any other function where time and date are entered by the user.
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Introduction
Remote Admin allows system administrators or support personnel to remotely access Messaging Admin from their own
workstation, eliminating the need to be in front of the server in order to perform administrative functions.

Visual Guide

On a typical setup, IX Messaging Admin only allows
a single user to directly access the server computer,
preventing other administrators from
accessing the system at the same time.

By utilizing Remote Admin, administrators are
able to access the IX Messaging Admin console
from almost any computer. Remote Admin also
enables multiple user support, allowing up to
5 administrators to be working on the system
at the same time.

Requirements
Requirements

Details

Software

Microsoft Windows Server 2012 and 2016
Microsoft Windows 7, 8, and 10.

Network

Workstations where remote admin is installed must be in the
same network domain as the Messaging voice server

Warning: Utilizing remote admin means that more than one person may be managing the database. If two or
more people make changes to the same entry, the first change may be overwritten without notification.
Note: The maximum number of people that can connect using Remote Admin is 5.
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Installing Remote Admin
Important: Avaya Messaging must be installed and operating normally on the voice server before proceeding.
Important: Remote Admin must be installed on the same subnet as the Avaya Messaging voice server, or the
Consolidated Server on a High Availability installation.
Remote admin must be installed on each workstation where it will be used.
1.

On the voice server, or on the Consolidated server in a High availability environment, locate the Messaging
installation directory (this is C:\UC by default). Share the UC folder with the Windows user(s) who will be running
Messaging Admin remotely.

2.

On a remote workstation, login and verify that this user has access to the UC folder on the server. Go to
\\ComputerName\UC and attempt open the folder (change ComputerName to the name of the server on your
system). If you can open the folder, then the share was a success and you can continue with the installation.

3.

Copy the \UC\RemoteAdmin\RemoteAdmin.exe file from the server to the remote machine.

4.

Launch (double-click) the program and the Remote Administration
Installation Wizard will start.
Click Next to begin the installation.

5.

When prompted, enter the computer name for the Avaya Messaging
voice server, or the Consolidated Server. Click Next.

6.

The program is ready. Click Next to begin installing the program.
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7.

Remote Administrator will be installed on the system.

8.

When finished, the wizard will report that the installation was
successful.
Click Finish to complete the installation.

Remote admin is now ready to be used. A shortcut will be placed on your Windows desktop to access the program.

Connecting to Remote Admin
To connect to Messaging Admin remotely, you will need the login credentials.
1.

Run the Messaging Admin shortcut from the desktop. The login screen appears.

2.

Enter the User Name and Password in the appropriate fields. Click OK.

Caution: The computer launching Remote Admin must be a member of the same
domain as the Messaging server in order to make the connection.
3.

You will be remotely connected to the Messaging Admin of the remote server.
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Introduction
The Messaging Remote Printer feature allows system administrators to remove printing functions from the voice server
and move them to another computer. This reduces the demand on the voice server CPU allowing for greater speed and
efficiency in processing voice data.
Remote Printer also permits the use of existing licenses for software that is not installed on the voice server. For
example, MSOffice and Adobe Acrobat must be installed on the voice server if faxes are to be sent in any of their
supported formats (doc, docx, pdf). Using Remote Printer to redirect this traffic to a machine that already has the
necessary software installed removes the need for additional licenses to be consumed by the voice server.
Remote Printer is included on the DVD with the standard release of Messaging. It is installed by default as part of
Messaging Admin. The Remote Printer program must be installed on the host, and the settings on the voice server must
be changed to point to the host machine.

Remote Printer Host Installation and Setup
Note: Messaging must be installed and properly configured on the voice server before proceeding with the
Remote Printer host installation. Refer to the Server Installation Guide and Server Configuration Guide for
more information.
The following instructions must be performed on the computer that is to act as the remote printer host.
1.

Run the UCPrint.msi program. This can be found on the Messaging DVD at:
D:\UC\UCPrint (change “D:\” to the correct location of your DVD drive).
Double-click this file to start the installation. The process takes a few seconds, and runs silently in the background.

2.

After a few moments, go to Start>Administrative Tools>Services and verify that the UC Remote Printer service is
installed and running. This service should be configured to start automatically.

Note: The Log On As account should be the same as that used during the installation of MS Office or
Adobe Acrobat Reader.
3.

Go to Start>Run and type regedit in the text entry box. Click OK.
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4.

On the left pane, navigate to either:
HKEY_LOCAL_MACHINE>SOFTWARE>Generic>EFSP (for 32-bit operating systems), or
HKEY_LOCAL_MACHINE>SOFTWARE>Wow6432Node>Generic>EFSP (for 64-bit operating systems).

32-bit Operating System Path

5.

64-bit Operating System Path

In the right pane, double-click UMSTServer and enter the IP Address
of the Messaging server for the value data. Click OK and close the
regedit screen.

The client side configuration is complete. Proceed with the setup of the Messaging voice server.
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Messaging Voice Server Remote Printer Setup
The following instructions are performed on the Messaging voice server.
Note: These instructions assume that Messaging has already been installed and configured on the voice
server. For details on the installation and setup of Messaging, please refer to the Server Installation Guide
and the Server Configuration Guide for details.
1.

Go to Start>Administrative Tools>IIS Manager. Verify that FTP is installed and running. This should already be
setup as part of the Messaging installation.

2.

Open Messaging Admin and click
Print Server.

3.

Right-click on Print Server and choose
Add.

4.

Fill in the required fields.
Description: Enter a descriptive name for the remote print server.
Workstation Name: Enter the PC name or the IP Address of the remote
printer host computer.
Available: Enable this checkbox.
Click OK when finished.

5.

In the right pane, double-click the local print
server and disable the Available checkbox.
Click OK when finished.

6.

Go to Start>Adnministrative Tools>Services and disable the UC Remote Printer service.
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7.

Go to Start>Administrative Tools>Services. Stop then start the following services:
UC Unified Messaging System Tasks Service and UC VPIMServer.

8.

On the computer acting as the remote printer host, stop then start the UC Remote Printer Service.

The setup of the Remote Printer feature is now complete.
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Introduction
While most business interactions occur digitally, faxing still remains a required feature for many people. This is especially
true when thee are technical limitations or legal requirements involved. Rather than having to purchase a fax machine to
handle this traffic, UC users can conveniently send faxes from their computer desktop digitally through the Messaging
server with the proper license and feature set enabled.

Requirements
The fax may be sent out from your computer through these methods:

•

Windows Fax Services: Send virtually any item as a fax as long as the software you are using to view the document
or image supports printing. You can send any content as a fax by printing it through the fax services integrated with
Messaging. However, this method requires some advanced configuration.
Refer to Fax via Windows Fax Services (Windows 7) on page 243 or Fax via Windows Fax Services (Windows
XP) on page 248 for more information.

•

Email Client: The advantage of this method is being able to send a fax from anywhere there is access to email client.
No additional configuration is required. Whether it is a web-based or a dedicated client, you can send a fax through
the Messaging server as long as there is access to email. However, you can only send files types that are supported
by the server. If the server does not recognize a certain type of file (i.e. docx, pdf), the fax request will fail.
Refer to Email to Fax on page 254 for more information.

•

Fax Gadget: This method is similar to the email client but has been streamlined for use with the Web Access
interface, either accessed directly or through client applications such as UC Web Gadget.
Refer to Sending a Fax through Fax Gadget on page 256 for more information.
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Fax via Windows Fax Services (Windows 7)
Configuration
Please follow these steps to configure your client machine with the Windows Fax services.
Warning: This configuration must take place before installing iLink Pro Desktop. If iPD has already been
installed, remove it, enable fax services, then reinstall the application.
Warning: Only TIFF and TXT formats are supported by default. To send a fax in any other format, the
computer must have the necessary program installed to support that file type (i.e. MicroSoft Office for doc and
docx files, Acrobat Reader 9 (available on the Messaging DVD) or earlier for pdf, etc.). Ensure that this software
is installed and working (run at least once) before attempting to send a fax using that format.
1.

Launch the Programs and Features
application within Control Panel.

Note: Change your viewing style to icons to
view the list of applications instead of
categories.

2.

Click on the Turn Windows features on or off
link on the left-hand pane.
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3.

From the feature window, enable the following features.
Print and Document Services
•
•

Internet Printing Client
Windows Fax and Scan

Click OK when you’re done.
Note: If these services are already installed on your computer, skip to
step 6.
4.

Windows will start to add the selected components. This process may take a while.

5.

If you are asked to restart your computer, click Restart Now to reboot.

6.

Once the computer has restarted, install iLink Pro Desktop.
Refer to the Client Applications Guide for more information.

7.

When iLink Pro Desktop has been installed, go to
Start > Programs and launch
Windows Fax and Scan.

8.

Go to Tools > Fax Settings...
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9.

From the General tab, confirm that the Device name is EEFSP.
If it is not, click on Select fax device... and choose it from the list.
You must also make sure that Allow this device to send faxes is enabled.
Allow the device to receive fax calls should be disabled since faxes are
received through the Messaging server. Only enable this checkbox if you have
a specific reason to do so.
Click OK to save your changes.

10. Open Tools > Fax Accounts...

11. Click the Add... button.

12. Select the Connect to a fax modem option.

Avaya Messaging Feature Description Guide

245

Avaya Messaging Faxing

13. Give the connection a name. You may leave it at the default
value, or change it according to your preference.
In most cases this item should be the only device configured
on your computer. If not, please ensure that
Use by default for sending faxes radio button is enabled
before continuing.
Click Next when ready.

14. Choose the Answer automatically (recommended) option.

15. If you are prompted regarding your Firewall, click to
Allow access at the bottom of the window.

Your computer is now ready to send fax messages.
Note: Keep in mind that you must be logged into iLink Pro
Desktop to send faxes.
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Sending Fax from an Application
Once your computer is configured for faxing, you can send faxes from any
application that can print using the Windows printing tool. To send a fax,
select Print from the application of your choice (e.g. Microsoft Office Word,
Adobe Acrobat). The Print windows appears.
Select Fax as the print device, then click Print.
Note: You must be logged into iLink Pro Desktop in order to send a
fax.

A new window will open to define the destination and any
other components required for the fax.
The document being sent as a fax will appear as an
attachment.
Ensure that you enter the correct fax number on the To:
field.
Set the Dialing rule to UC Location.
All other fields, such as Cover Page, Subject and Body are
optional fields which you can utilize to customize your fax
message.
When you are ready to send the fax, click the Send button.

The Fax status window will appear to notify you of the fax’s
status. Once transmission has completed successfully, you will be
notified here.
If the fax fails for any reason, the details will be shown here. Consult
with your system administrator if you are having trouble sending
faxes.
Note: You can track of all your outgoing faxes from the
Windows Fax and Scan application available on the Start
menu.

Avaya Messaging Feature Description Guide

247

Avaya Messaging Faxing

Fax via Windows Fax Services (Windows XP)
Configuration
Please follow the below steps to configure your client machine for use with Windows Fax services.
Warning: This configuration must take place before installing iLink Pro Desktop. If iPD has already been
installed, remove it, enable fax services, then reinstall the application.
Warning: Only TIFF and TXT formats are supported by default. To send a fax in any other format, the
computer must have the necessary program installed to support that file type (i.e. MicroSoft Office for doc and
docx files, Acrobat Reader 9 (available on the Messaging DVD) or earlier for pdf, etc.). Ensure that this software
is installed and working (run at least once) before attempting to send a fax using that format.
1.

Go to Start > Settings > Control Panel. Double-click Add/Remove Programs.

2.

Select Add/Remove Windows Components.

3.

Enable Fax Services. Click Next.

Note: You may be asked to provide a Windows installation disc depending on the computer settings.
4.

Once the process is complete, you will have the ability to send faxes from your desktop.
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Sending Fax from an Application
1.

Open the document or image that will be sent as a fax.

2.

Print the item. This is normally under the File > Print menu.

3.

When the print dialogue appears, select fax as the print device.
Click OK.

4.

The Send Fax Wizard screen appears:

5.

Click Next. The Recipient Information screen
appears:

6.

Specify the following:
•

In the To field, enter the name of the intended
recipient.

Hint: Click the Address Book button to select a
recipient from your personal address book.
•

•

•

From the Location dropdown list, select the
location (country) of the intended
recipient.
In the Fax number fields, specify the fax area
code and number for the intended
recipient.
Enable Use dialing rules if you want specific
dialing rules to apply. Select the dialing rules
from the accompanying dropdown list.

Note: To create a new set of dialing rules, click on the Dialing rules button.
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7.

Click on the Add button to add the recipient whose information you have just specified.

Note: You can add as many recipients as you wish.
8.

Click Next when you have added all desired
recipients. The Preparing the Cover Page screen
appears:

9.

From the Cover page template dropdown list,
select the cover page template you want to use.

10. In the Subject line field, enter subject text for the
fax cover page.
11. In the Note box, enter message text for the fax
cover page.

12. Click Next. The Schedule screen appears:
13. Select one of the When do you want to send this
fax? radio buttons:
Now - send the fax immediately
When discount rates apply - send the fax the
next time discount phone rates apply
Specific time in the next 24 hours - send the
fax at a specific time in the next 24 hours. If
you select this radio button, you must then
specify a time of day from the
accompanying spin-box
14. Select one of the following What is the fax
priority? radio buttons:
High - high priority for sending fax
Normal - normal priority for sending fax
Low - low priority for sending fax
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15. Click Next. The following screen appears:
16. If you want to preview your fax, click on the
Preview Fax button. Otherwise, click Finish.
Hint: To confirm that your fax was sent successfully,
check the Sent Items folder of your Fax Console
application.
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Viewing the Status of a Fax
1.

Select Start > All Programs > Accessories >
Communications > Fax > Fax Console.

2.

In the left hand pane, click to expand Fax. The
following list describes the folders under Fax:
•
•
•
•

The Incoming folder contains faxes that are
currently being received.
The Inbox folder contains faxes that have been received.
The Outbox folder contains faxes that are scheduled to be sent.
The Sent Items folder contains faxes that have been successfully sent.

3.

In the left hand pane, highlight a folder.

4.

In the right hand pane right click on the fax you want and select Properties.

5.

On the General tab, check the status of the fax under Status.

Note: If an item is in the Outbox folder, then the fax attempt has failed. Until all retries have been
exhausted, Status will read Pending. If all retries have been exhausted, Status will read Failed.

Receiving and Viewing a Fax
1.

Select Start > All Programs > Accessories > Communications > Fax > Fax Console. The Fax Console detects
incoming faxes and stores them in your inbox.

2.

To view a fax click Inbox, then double click on the fax you want to view.

Canceling a Fax Job
You can cancel any fax you have set up to be sent at a future time.
1.

If Fax is not open, select Start > All Programs > Accessories > Communications > Fax > Fax Console. The Fax
Console appears.

2.

To cancel a fax click Outbox, then right click on the fax you want to cancel.

3.

Click Delete to cancel the fax.

4.

Click Yes.
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Automatically Send Retry
You can set up Fax so that it continues trying to send your fax if the receiving fax machine is busy.
Note: Fax is automatically set up to retry three (3) times at 10-minute intervals.
1.

Select Start > Control Panel. The Control Panel appears.

2.

If your Control Panel is in Category View, click Printers and Other Hardware. Click View installed printers or fax
printers. The Printers and Faxes screen appears.
OR
If your Control Panel is in Classic View, double-click the Printers and Faxes icon. The Printers and Faxes screen
appears.

3.

Right click Fax and select Properties. The Fax Properties dialogue box opens.

4.

Click the Devices tab, then Properties. The Modem dialogue box opens.

5.

Specify the number of retries and the amount of time between retries.

6.

Click OK.

Automatically Canceling a Fax
If your PC tried to send a fax and failed to connect to a fax machine, you can automatically cancel a failed fax.
1.

Select Start > Control Panel. The Control Panel appears.

2.

If your Control Panel is in Category View, click Printers and Other Hardware. Click View installed printers or fax
printers. The Printers and Faxes screen appears.
OR,
If your Control Panel is in Classic View, double-click the Printers and Faxes icon. The Printers and Faxes screen
appears.

3.

Right click Fax and select Properties. The Fax Properties dialogue box opens.

4.

Click the Devices tab, then click Properties. The Modem dialogue box opens.

5.

Click the Cleanup tab.

6.

Click to check Automatically delete failed faxes after and specify the number of days.

7.

Click OK.
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Email to Fax
Note: The example shown in this guide uses Gmail. However, this process can be repeated with virtually
any email client including web based email, MS Office 365, and MS Exchange.
Email to Fax requires no user-end configuration. The only requirement is that the fax email is sent to the correct domain
using the correct format.

Administrator Setup
Warning: Only TIFF and TXT formats are supported by default. To send a fax in any other format, the
computer must have the necessary program installed to support that file type (i.e. MicroSoft Office for doc and
docx files, Acrobat Reader 9 (available on the Messaging DVD) or earlier for pdf, etc.). Ensure that this software
is installed and working (run at least once) before attempting to send a fax using that format.

•

The network administrator must setup an MX Record that points vpim.yourcompany.com to the IX Messaging voice
server (or the Consolidated Server in an HA environment).

•

Send URL must be configured and activated on the voice server (see the Security Enhancements chapter in Avaya’s
Server Configuration Guide).

•
•
•

SMTP port 25 needs to be opened on any firewall or security services.
An active email account and client are also required.
Under Messaging Admin>Configuration>VPIM/SMTP, set Use email verification for outbound faxing to True.
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Sending a Fax
Create a new email message. In the To... field, type
fax= followed by the number of the destination fax
machine at(@) your company’s server. For example,
fax=1234567890@companydomain.com.
The Subject line and the email message body will be
included with the fax as a cover page.
Include the main body of the fax as an attachment
to the email.
Note: Only TIFF and TXT formats are supported
by default. However, if the server has the
appropriate programs installed, other formats
can be used (PDF requires Acrobat 9 (available
on the Messaging DVD), DOC / DOCX need MS
Office).
Send the email when you’re ready.
The message will be accepted by your server and processed into an outgoing fax job.

Fax Activation
To prevent spam, once you have clicked the Send button, the Messaging Server will send you an email to confirm that the
fax message is to be sent.
This email includes a link which you must click on to authorize the server to send the fax message. Click on the link.

The system will respond with a message verifying that the fax has been queued for sending. The message status can now
be tracked in the fax status report folders.
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Sending a Fax through Fax Gadget
The Fax Gadget appears. This can be accessed through Web Access directly, or through a link from
other web applications such as Avaya iLink Pro.
To send a fax, click Send a Fax.
Note: Send a Fax will only available if you have a fax board installed on the server to
handle fax routing. Otherwise, faxes can be sent by clicking Send a Message and setting
the outgoing address to FAX: followed by the fax number (e.g. fax:9057079700).
On the To field, enter the fax destination number.
It is best to provide all numbers including both country and
area code (e.g. 1-123-765-4321).
When you enter the full fax number on this field, the Fax
Gadget will automatically add the Fax: qualifier to indicate
that this is a fax message.
Click on the Attachments tab to add content to this fax
message. Any attachments to the fax must be in the PDF or
TIFF formats unless the UC server has been specifically setup
to support other file types.
Click the Add button to open the menu shown here.
Select File from the menu and click Choose File... to browse for the file to
be sent as the fax content.
Once the file has been chosen, click Upload.

The selected file will now be added as fax content.
Click Send to transmit the fax immediately.
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The fax message you’ve sent will now be listed under Fax Jobs. You
will be able to easily check on the status of the fax to ensure that it
has been sent out.
If the status doesn’t change to Sent within a reasonable amount of
time, or if the fax message fails repeatedly, please contact your
system administrator for help regarding the matter.
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Fax Jobs
Whenever a fax message is sent or received by the UC server, an entry will appear in Admin > Fax Jobs so that the
administrator can easily view and manage faxing. All fax jobs will appear in one of three folders and will be moved
accordingly.
Outgoing: This folder contains the details of all faxes that are currently being sent that have neither finished nor
failed.
Completed: This folder contains the details of all faxes that have been successfully sent.
Failed: This folder contains the details of all faxes that could not be sent. The system has stopped trying to send the
fax.

Each of these folders contains the following information for each fax message:
Number: This field displays the job number assigned to the fax.
Sender: This field displays the individual who sent the fax.
Destination: This field displays the Mailbox number to which the fax is directed.
Status: This field displays the current status of the fax (Initial / Pending / Sending / Sent / Canceled / Failed-Busy
/ Failed-No Answer / Failed-Other / Failed).
Created: This field displays date and time the fax was sent.
Completed: This field displays date and time the transmission of the fax was completed.
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Introduction
Messaging permits high volume fax users to integrate their Dialogic SR140 fax software with the voice server platform.

Pre-Requisites
Install the Messaging program onto the computer that will act as the Voice Server. Ensure that the Hardware Fax
Drivers option is installed at the Features Selection screen during program installation. This will ensure that the
necessary program elements are included with Messaging.
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Configuration
Once both the Dialogic SR140 and the Messaging voice server have both been installed, the fax software must be
configured to communicate with the UC platform.
The following procedures must be performed on each computer that is running the SR140 software.

License Manager
1.

Open the Brooktrout License Manager program.

2.

Enable the SR140 license by clicking on the Activate button.

Note: The procedure shown here uses the Activation Wizard and an Internet connection.
If you have a license file, select Install and point the program to the file provided by your vendor.
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3.

Click Next.

4.

Make sure that Automatically is selected as the Activation Method, then click Next.

5.

Currently, no License Keys are installed. Click Add.

6.

Enter the SR140 license key number that came with the fax software package. Click OK when ready.
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7.

The new license key has been successfully added to the system. Click Next.

8.

Click Next to continue to the Product Registration pages.

9.

Enter the details of the site administrator. All fields are required for registration. Click Next when ready.
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10. Enter all of the required information into the fields provided. This is the site where the software is installed.
Click Next to continue.

11. The program will connect to the Dialogic servers to upload the registration details. This requires a working Internet
connection, and must be completed successfully before the license will be activated.
When it has finished, click Next to continue.

12. The new license has been added to the Wizard. Click Next.
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13. Click Next to complete the activation Wizard.

14. The added license appears in the Brooktrout License Manager.

Avaya Messaging Feature Description Guide

265

Dialogic SR140 Fax Integration

Configuration Manager
1.

Open the Brooktrout Configuration Manager program.

2.

At Configuration Tool - Preferences, change Boston Host Service Start Mode to Automatic and click OK.

3.

When the Configuration Wizard starts, choose Advanced Mode.
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4.

Enable the option for SIP. Click OK to continue.

1.

Select BTCall Parameters (All boards).
Enter the path to the appropriate file in the space beside Country Telephony Parameter File. By default, this will be:
C:\Program Files\Brooktrout\config\BT_CPARM.cfg
Modify the path according to the location where your administrator has installed the program.
Select your Country from the dropdown list.

2.

In the left-hand window, select SIP under IP Call Control Modules. Go to the T.38 Parameters tab.
For Fax Transporting Protocol, the recommended value is T.38 only.
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3.

Move to the IP Parameters tab.
For Primary Gateway, enter the IP address and port number to be used for all outbound fax traffic.

4.

For Contact IPv4 Address, enter sr140@ followed by the IP address and port used for inbound faxing. This must be
a different port than the one used for the Messaging voice server (5060).

5.

Click Save to confirm the changes.

6.

Click Apply to restart all affected services.

The configuration of the SR140 software is complete.
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Messaging Configuration
The voice server must be configured to send faxes to the SR140, and to prepare to receive them across the same channel.
A setting for incoming, and another for outgoing faxes must be configured on the server using Messaging Admin.
1.

Go to Start > All Programs > Messaging > Messaging Admin, or click the Messaging Admin icon on the server
desktop. Enter the username and password at the prompt.

2.

Open Configuration and click on Fax Settings.

3.

In the right-hand pane, locate the entry for Fax Board Type. Double-click to open its settings.
From the dropdown menu, choose Brooktrout SR140.
Click OK.

4.

Double-click on Outbound Fax Board Type. Choose Brooktrout SR140 from the dropdown menu.
Click OK.

Hint: If faxes will only be received through the SR140 software, the Outbound Fax Board Type can be set to
another value if required.
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5.

Under Voice Server, select your voice server. Double-click Soft Fax Channels and change its value data from 0 to
the number of channels you have. Click OK when finished.

6.

Double-click Start Fax Channel Number and change its value data to 1. Click OK when finished.
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7.

Open Configuration > Advanced. Set Disable Fax Detection to False for all entries shown.

8.

Go to Configuration > Fax Settings.
Double-click Dialing Suffix and set the Value Data field match your Outside Line Access Code. Click OK.
Double-click Fax Board Type and set the Value Data field to Brooktrout SR140. Click OK.
Double-click Fax Mail Installed and set the Value Data field to True. Click OK.

9.

Restart the voice server.
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10. Once the server is online, open UC Admin and under Voice Server, verify that the Fax Enabled field is set to True.

11. Setup one mailbox to be used as the default destination for incoming fax traffic.
In UC Admin, double-click your company to open the properties window.
On the General tab, locate Fax Extension and specify which mailbox to send faxes into.
When ready, click Save.
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12. Inbound faxes require routing calls through port 5070 to IXM since Brooktrout listens on that port. This requires a
DID for each mailbox configured for fax. Add the fax DID number in the Addresses tab of the mailbox. This can be
an internal number for the fax DID. For example, for DID 705 213 4567, add the fax extension 4567 which can be
dialed from outside and will be routed through port 5070 and will be received into that mailbox. If not properly
configured, the fax will be sent to the default system mailbox.
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Monitoring Channel Activity
Setup
To monitor the traffic through the fax software, the configuration file on the Messaging Voice Server must be setup to
point to the correct file locations.
1.

On the computer where Messaging is installed, use a text editor (i.e. Windows NotePad) to open the configuration
file. By default, this will be:
C:\UC\ETBTFax\Config\ETBTFaxService.ini
Modify the path according to the location where your administrator has installed the program.

2.

Modify the Config entry to include the full path to the btcall.cfg file. By default, this will be:
“C:\Program Files\Brooktrout\config\btcall.cfg”
Be sure to enclose the path within double quotation marks “ ”.
Modify the path according to the location where your administrator has installed the program.
Enter the HTTP Port number that will be used to monitor fax channel activity.

3.

When all changes have been made, click File > Save.

Monitoring via Browser
To monitor activity on a fax server, open a browser and navigate to:
http:\\localhost:30070
Change localhost to the IP address of the fax server if you want to monitor from a different computer.
Change the port number (30070 in this example) to the value entered in step 2 above.
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Introduction
Messaging can be setup to securely send and receive faxes through the Dialogic SR140 fax software. The transmissions
use Transport Layer Security (TLS) to encode the data. This method complies with JITC requirements for secure
communications.
Sites receiving secure faxes must also be setup to use the TLS protocol. Incoming faxes must also be secured using TLS
protocols.

Pre-Requisites
Install the Messaging program onto the computer that will act as the Voice Server. Ensure that the Hardware Fax Driver
option is enabled at the Features Selection screen during program installation. This will ensure that the necessary
program elements are included with Messaging.

For High Availability (HA) installations, the SR140 can be installed on the Primary or any of the Secondary servers.
Important! Secure Fax using the SR140 fax software requires 2 licenses from Dialogic; the standard fax
license, and a secure fax license.
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Configuration
Once the Dialogic SR140 and the Messaging voice server are both operating, the fax software must be configured to
communicate with the UC platform.

License Manager
1.

Open the Brooktrout License Manager program.

2.

Enable the SR140 license by clicking the Activate button.

Note: The procedure shown here uses the Activation Wizard and an Internet connection.
If you have a license file, select Install and point the program to the file provided by your vendor.
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3.

Click Next.

4.

Enable Automatically... as the Activation Method, then click Next.

5.

Currently, no License Keys are installed. Click Add.

6.

Enter the SR140 standard license key number that came with the fax software package. Click OK when ready.
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7.

The new license key has been successfully added to the system. Click Add.

8.

Enter the SR140 secure fax license key number. Click OK.

9.

Both license keys have been successfully added to the system. Click Next.

[

]

10. Click Next to continue to the Product Registration pages.
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11. Enter the details of the site administrator. All fields are required for registration. Click Next.

12. Enter the details for the location where the software is installed.
Click Next to continue.

13. The program will connect to the Dialogic servers to upload the registration details. This requires a working Internet
connection, and must be completed before the license will be activated.
When it has finished, click Next to continue.
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14. The new licenses have been activated on the system. Click Next.

15. Click Finish to complete the Wizard.

16. The added licenses appear in the Brooktrout License Manager.
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Configuration Manager
1.

Open the Brooktrout Configuration Manager program.

2.

At Configuration Tool - Preferences, change Boston Host Service Start Mode to Automatic and click OK.

Hint: This screen will only appear the first time you run the program. Thereafter, this screen will be skipped.
3.

When the Configuration Wizard starts, choose Advanced Mode.
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4.

Enable the stack option for SIP, then click OK to continue.

Hint: This screen will only appear the first time you run the program. Thereafter, this screen will be skipped.
5.

In the left-hand panel, click SIP beneath IP Call Control Modules. Go to the IP Parameters tab and specify the
following for your site.

Primary Gateway: Enter the IP address of the Avaya Aura Communication Manager server. This was initially
configured on the device. Add the port value that the CM uses for faxing in the second field.
From Value: In this field, (including the quotes) type “ETBTFax” <sip:etbtfax@ followed by the IP address of
the Avaya Messaging voice server. For example: “ETBTFax” <sip:etbtfax@192.168.0.1> .
Contact IPv4 Address: Add sr140@ followed by the IP address and the port used by the Messaging voice
server. For example: sr140@192.168.0.1:5061 .
Session Name: Enter sr140 in this field.
When ready, click Show Advanced>>.
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6.

Specify the following for your site.

IP Preference for SIP: Select IPv4 only from the dropdown list.
IPv4 Interface Port: Enter the port used for faxing.
IPv6 Interface Port: Enter the port used for faxing.
TCP Enable: Set this to TRUE.
Transport Protocol: Choose TLS from the dropdown list.
SIP over TLS Enable: Set this to TRUE.
SIP over TLS Port: Enter the port used for faxing.
Block UDP port: Set this to FALSE.
Block TCP port: Set this to TRUE.
Secure RTP Enable: Set this to TRUE.
FIPS Enable: Set this to FALSE.
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7.

Go to the T.38 Parameters tab and specify the following for your site.

8.

Click Save, then Apply.

9.

On the Avaya Messaging voice server, go to the installation drive and locate the folder
\Program Files (x86)\Brooktrout\config .

Fax Transport Protocol: Select G.711 pass-through only from the dropdown list.
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10. In the folder, open the SRTP.cfg file using a text editor such as NotePad.
Remove the # (uncomment) at the start of the following lines, and verify their values are as shown.

srtp_accept = true
srtp_enforce = true
srtp_crypto_suite = AES_CM_128_HMAC_SHA1_80
srtcp_unencrypted_flag = true
Save the file when finished.
11. Open the SIPTLS.cfg file.
Remove the # (uncomment) at the start of the following lines, and verify their values are as shown.

sip_tls_method = : Leave this field at its default value.
local_rsa_private_key_filename = : Enter the path to the location of your private key file.
local_rsa_cert_filename = : Enter the path to the location of your server certificate file.
ca_cert_number = : Put the number of the cert you are using here. Add as many as are required.
ca_cert_filename = : Put the name of the certificate file you are using here. Add as many as are required.
(optional) chain_cert_number = : Put the number of the cert you are using here. Add as many as are required.
This is only required if you are using Intermediate certificates.
(optional) chain_cert_filname = : Put the name of the certificate file you are using here. Add as many as are
required. This is only required if you are using Intermediate certificates.
client_cert_required = false
allow_self_signed_certs = false
12. When finished, restart the UC BTFaxServer and the Dialogic Corporation Boston Host Service services on the
computer, or reboot the server.
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Avaya Aura Communication Manager Configuration
The certificate files must be copied to the AACM server.
1.

Login to the AACM server using administrator credentials. Go to Administration > Server (Maintenance).

2.

Go to Miscellaneous > Download Files.
Enable the File(s) to download from the machine I’m using to connect to the server radio button.
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3.

Click Choose File and find the certificate file. Select the file and click Open to add it to the list.
Repeat for each certificate file (CA, Intermediate, Server, etc.).

When finished, click the Download button to copy the files to the server.
4.

In the left-hand column, select Security > Trusted Certificates.
Click Add and attach each of the CA and Intermediate certificates downloaded in step 3.

5.

In the left-hand column, click Server/Application Certificates.
Click Add and attach the server certificate downloaded in step 3.

6.

Close the Communication Manager console.
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Avaya Aura System Manager Setup
1.

Login to the System Manager using an administrator account.
Under Elements, select Communication Manager.

2.

Go to Network > IP Codec Sets.
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3.

Add / Edit an audio codec set.

Audio Codec: Set this to G.711MU.
Silence Suppression: Choose n.
Frames Per Pkt: Enter a value of 2.
Media Encryption: Select 1-srtp-aescm128-hmac80 from the dropdown list.
4.

Go to IP Network Regions in the left-hand column. Click New to create an entry.
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5.

Enter an available Network Region qualifier (a number between 1-250), then click Add.

6.

Enter the following parameters.

Name: Enter a meaningful, human readable name.
Codec Set: Set this to the codec set number configured in step 3.
UDP Port Min: Enter 2048 here.
UDP Port Max: Enter 8001 here.
Click the ENTER button when finished.
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7.

Open Node Names in the left-hand column. Click New.

8.

Select IP from the qualifier dropdown list, then click Add.
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9.

In a blank space on the page, name the node, then enter the IP address of the Avaya Messaging voice server.
When ready, click the ENTER button.

10. Open Signaling Groups in the left-hand column. Select an existing group (typically group 1) to edit, or create a new
group. If creating a new group, when prompted for a Qualifier, enter NEXT.
Enter the required values.

Group Type: Choose SIP from the dropdown list.
Transport Method: Select tls from the dropdown list.
Enforce SIPS URI for SRTP: Set this value to n.
Near-end Node Name: Enter the value procr in this field.
Far-end Node Name: Enter the Node Name from in step 9.
Near-end Listen Port: Enter the port number used for faxing.
Far-end Listen Port: Enter the port number used for faxing.
Far-end Network Region: Enter the network region used as the qualifier in step 5.
When ready, click the ENTER button.
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11. Open Trunk Groups in the left-hand column. Select an existing group (typically group 1) to edit, or create a new
group. If creating a new group, when prompted for a Qualifier, enter NEXT.

TAC (Trunk Access Code): Enter any unique number. Any four digits, or # and *
Group Type: Select SIP from the dropdown list.
Signaling Group: Enter the number of the signaling group from step 10.
Service Type: Select tie from the dropdown list.
Number of Members: Type in 255 for this value.
When ready, click the ENTER button.
12. Open Route Pattern in the left-hand column. Click New to create a group. Give it the number of the Trunk Group
specified above (step 11), then click Add.

Avaya Messaging Feature Description Guide

294

Dialogic SR140 Secure Fax

13. Enter the values required.

Grp No : Enter the trunk group number configured in step 10.
No. Del Dgts: Usually, set this value to 0.
Pattern Name: Give the route pattern a human readable name.
Numbering Format: Select lev0-pvt from the dropdown list.
When ready, click the ENTER button.
14. Open Automatic Alternate Routing Analysis in the left-hand column. Click New and enter the hunt group number
for your system. Or select an existing extension and choose Edit. Click Add.
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15. Modify a Dialed String entry.

Min / Max: Set these values to the longest or shortest number that can be entered.
Route Pattern: Enter the number of the Route Pattern created in step 12.
Call Type: Select lev0 from the dropdown list.
When ready, click the ENTER button.
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Messaging Configuration
The voice server must be configured to send faxes to the SR140, and to prepare to receive them across the same channel.
A setting for incoming, and another for outgoing faxes must be configured on the server using Messaging Admin.
1.

Go to Start > All Programs > Messaging > Messaging Admin, or click the Messaging Admin icon on the server
desktop. Enter the username and password at the prompt.

2.

Open Configuration and click on Fax Settings.

3.

In the right-hand pane, locate the entry for Fax Board Type. Double-click to open its settings.
From the dropdown menu, choose Brooktrout SR140.
Click OK.

4.

Double-click on Outbound Fax Board Type. Choose Brooktrout SR140 from the dropdown menu.
Click OK.

Hint: If faxes will only be received through the SR140 software, the Outbound Fax Board Type can be set to
another value if required.
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Ch. 22 - Web Access
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Introduction
Business today requires flexibility and mobility. Company personnel find it increasingly necessary to go where the
customers are. Advances in technology allow people to work from home or other locations away from the office. The
Messaging Web Access is an Internet browser based application that gives users on a UC system the ability to manage all
aspects of their communication and schedule from any Internet enabled computer. The Mobile Web Access works with
mobile devices as well.
Email, fax and voice messages can be accessed and dealt with. Users can also update their current location. Personal
calendars are also available for viewing and modification. Wherever you may need to travel, Web Access will be there to
help keep you in touch.

Getting Started
Note: Use Google Chrome for best results. Other web browsers may not be fully supported or provide
access to all features.
To launch Web Access, open a web browser and navigate to the corporate UC server site. Click the Web Access icon to
start the program.

These links provide multiple authentication methods to access Web Access, some of which may be disabled by your
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administrator. Select the credentials to use and login.

Note: This screen does not appear if you login without having logged out from a previous session.

Logging In
Refer to the Client Applications Guide, page 218, for complete details on signing on to Web Access.

Navigation
Web Access consists of five major sections: Messaging, Location, People, Notification and Settings.
Through these menus, you have access to all of your messages (voice, fax, and email), and can respond to, delete and
mange them. You also have complete access to manage your UC presence, location, schedule and contacts.

For more details on Web Access, please refer to Web Access on page 217 of the Client Applications Guide.
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PASSWORD RESET
Ch. 23 - Password Reset

Accessing an account requires a password. The voicemail and application passwords can be reset through any web
browser from the UC Server web page.
1.

Using any web browser, enter the URL for the voice server (i.e. user.yourcompany.com). Select Reset Password.

2.

Enter an email address and select the password to reset: reset Voicemail Password or Application Password.

3.

Enter the security code in the space provided, Click Send a Request when ready.

4.

The specified email address will receive a message with a link. Click on the link to enter the details of the new
password.
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5.

Enter a new password in the spaces provided, then click Reset Password.

6.

The account password will be changed to the new value.
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Ch. 24 - Web UM Monitor

Introduction
The Web UM Monitor is a suite of tools to watch the performance of the system for the purposes of troubleshooting.

Getting Started
Note: Use Google Chrome for best results. Other web browsers may not be fully supported or provide
access to all features.
1.

To launch Web UM Monitor, open a web browser and navigate to the corporate UC server site. Click the UM Monitor
icon to start the utility.

2.

Enter the administrator username and password for the voice server.
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3.

From the dropdown menu, select the voice server you want to monitor.

4.

Click Connect to begin monitoring the voice server.

Hint: When finished, click Disconnect to stop monitoring that voice server.
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The Channels Tab
The Channels Tab is the starting point for the program. In this panel is displayed the current status of each channel
working on the voice server.

Hint: To view only a range of channels, enter the starting channel number in the box and click Apply. Only the
channels from there up to the last will be shown.
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The View Status Tab
This pane shows the commands that are being sent and received through all of the voice server channels.

Select either All channels or a specific channel to monitor from the dropdown list.
Use Clear to remove all status entries from the display. New status entries will begin to fill the screen.
Enable Stop scrolling to freeze the window. New entries will continue to be added to the bottom of the list, but the pane
will not move until you manually begin scrolling.
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The View Trace Tab
The View Trace tab allows you to get a clearer idea of what each channel is doing.

Select either All channels or a specific channel to monitor from the dropdown list.
Use Clear to remove all status entries from the display. New status entries will begin to fill the screen.
Enable Stop scrolling to freeze the window. New entries will continue to be added to the bottom of the list, but the pane
will not move until you manually begin scrolling.
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Sending Commands
Use Send Commands to issue commands directly to the voice server.
Enter the command into the space provided and click the Enter button.

You can also view all available commands and their format by clicking the link.
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Display License Details
This menu displays the details of the license for the selected voice server.
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Introduction
Avaya CPaaS is a robust development platform — create what you need and integrate it seamlessly with Avaya Messaging
and go!
Integrating with an Messaging system, either on a single server or high availability installation, gives you the ability to
receive SMS messages through a number purchased on Avaya CPaaS, anywhere in the world. Messages are delivered
directly to your IX Messaging mailbox.

Pre-requisites
•
•
•

Officelinx 10.5 or later.
An Internet connection.
An Avaya CPaaS account and telephone number.
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Avaya CPaaS Configuration
An account with Avaya Cloud must be setup, and a number with support for SMS messaging must be purchased from
Avaya CPaaS.
1.

Open an Internet browser and go to cloud.zang.io. Enter your Avaya Cloud account credentials and click Log In.

If you do not already have one, you can create a new account now. Enter your email address in the space provided,
click Yes, sign me up! and follow the prompts to create a new account.

2.

New accounts are given a few dollars to get started. If necessary, click Add Funds and add cash to your account
balance. Numbers typically cost from $1 to $3 / month, depending upon the country and if it is local or toll free.
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3.

With your account properly funded, select Numbers and click Buy a Phone Number.

4.

Choose between Local or TollFree numbers.
Select the country that will host the number. You can also enter the area / city code to narrow the search. Leave the
search field empty to view all numbers available in the selected country.
When ready, click Search and the list of available numbers will appear.

5.

Locate the number you want. For the number to work with Messaging, the number must support SMS Messaging. In
the Features column, look for numbers that have a blue

icon indicating that the number can be used with

incoming SMS messages. Number with gray
icons do NOT have that feature available.
When you have located a suitable number, click Buy to add the number to your account.
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6.

From the Avaya CPaaS Dashboard, record the Account SID and the Auth Token values.

Continue with the configuration of Avaya Messaging.
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Avaya Messaging Voice Server Configuration
The configuration of Avaya Messaging is done using the Messaging Admin program on the Voice Server. In a High
Availability environment, the configuration is done on the Consolidated Server only.
1.

On the Messaging Voice Server, or the HA Consolidated Server, open Messaging Admin and login.

2.

Go to Configuration > Advanced and scroll down to the SMS options.
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3.

Make the following configuration changes. For each entry, double-click the item and modify the details where
necessary.

•
•
•

SMS Provider: From the dropdown menu, select Avaya Cloud. Most of the other fields should be filled in
automatically.
SMS Account Username: Enter the Account SID of your Avaya CPaaS account.
SMS Account PIN: Enter the Auth Token of your Avaya CPaaS account.

Avaya Messaging Feature Description Guide

319

Integration with Avaya CPaaS

Avaya Messaging User Configuration
The Avaya CPaaS telephone number must be associated with a user’s mailbox to ensure that the SMS messages are
delivered correctly. There are four methods that you can use. Some require changing the user mailbox through
Messaging Admin, others need an INI file to route incoming messages, and two require the sender to include additional
addressing details in the body of the message.
Pick the one that best matches your needs.

One-to-one:
•

Personal number / Direct number: Each user has their own dedicated Avaya CPaaS telephone number.

Any-to-many
•

Mailbox / Keyword: Your company has one or more Avaya CPaaS telephone numbers, each supporting many users.
METHOD

MODIFY MAILBOX

INI FILE ENTRY

SENDER ADDRESSING

Personal number
Direct number

Mailbox
Keyword
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One-to-one
Use one of these methods if each user has exclusive use of a Avaya CPaaS telephone number.

44 20 3002 6798

905 707 9700

Personal number
Associating the number with the mailbox is done by modifying the user profile in Messaging Admin.
No INI file entry or additional Sender Addressing is required.
1.

In Messaging Admin, open the PBX and go to the Company menu. Select Mailbox Structure.
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2.

Double-click a user and open the Addresses tab.

3.

Click Add and choose SMS Phone.

4.

Enter the required information and click OK when ready.

•
•
•
•
•

Description: Give this address a label.
Country: From the dropdown menu, select the country that this number applies to.
Area/City Code: Enter the city or area code for this number.
Number: Enter the Avaya CPaaS telephone number here.
Set as Default: This field should be disabled.
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5.

The new address has been added to the user. Click Save.

All incoming SMS messages sent to the Avaya CPaaS telephone number will be directed to this user’s mailbox.

Direct number
Associating the number with the mailbox is done through the INI file.
No additional Sender Addressing or changes to the user profile are required.
1.

Open a text editing software program such as Windows Notepad and create/modify the INI file.

2.

Each person using Direct number must have an entry in the INI file, and each entry contains four elements.

[Application1]
Number= 1(905)707-9700
Mailbox= 9876
Company= 1
[Application2]
Number= 1(905)707-9170
Mailbox= 9877
Company= 1
•
•

[ApplicationX]: This is an incrementing label, ApplicationX, where X is a unique identifier for each user (i.e.
[Application1] , [Application2] , etc.). There are no spaces in this title, and it must be enclosed in square brackets.
Number= : Specify the Avaya CPaaS telephone number for the recipient. This is where the sender addresses the
message.

Caution: The number in an incoming message must match this value exactly or the message cannot be delivered.
•
•

Mailbox= : Enter the mailbox for the recipient. The incoming SMS message will be delivered here.
Company= : For sites that have multiple tenants / companies, enter the company number for this user here.
This value must match the company numbers defined on the Avaya Messaging voice server. In most cases,
where there is only a single company using the server, set this value to 1.
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3.

Once all users have been added, save the file with the name: http2smsconnector.ini
Save it on the Messaging Voice Server installation drive in the UC/SMS folder.

4.

Stop and re-Start the UC SMSConnector service on the Voice Server, or reboot the server.
This service should also be configured to start automatically.

Note: You can combine both Direct number and Keyword entries in the same INI file. Only the
information in each entry will change.

[Keyword1]
Value= ASKJohnC,JohnC
Mailbox= 9876
Company= 1
[Application1]
Number= 1(905)707-9700
Mailbox= 9876
Company= 1
All incoming SMS messages sent to the Avaya CPaaS telephone number will be directed to the user’s mailbox defined in
the INI file.
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Any-to-many
Use one of these methods if your company has one or more Avaya CPaaS telephone numbers with many people using
each one.

44 20 3002 6798

905 707 9700

Mailbox
The sender must begin the message with ## followed by the mailbox number of the recipient. This mailbox must be
followed by

or

.

Associating the number with the mailbox is done explicitly by the sender within the body of the message.
No INI file entry or changes to the user profile are required.

All incoming SMS messages sent to the Avaya CPaaS telephone number will be directed to the user’s mailbox based upon
the value that the sender includes within the body of message.
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Keyword
A unique Keyword is used to identify the recipient of the message.
Associating the number with the mailbox requires both addressing within the body of the message and an entry in the
INI file.
No changes to the user profile are required.
1.

Open a text editing software program such as Windows Notepad and create/modify the INI file.

2.

Each person using Keyword must have an entry in the INI file, and each entry contains four elements.

[Keyword1]
Value= ASKJOHNC,JOHNC
Mailbox= 9876
Company= 1
[Keyword2]
Value= ASKALF,ALANF
Mailbox= 9877
Company= 1
•
•

[KeywordX]: This is an incrementing label, KeywordX, where X is a unique identifier for each user
(i.e. [Keyword1], [Keyword2] , etc.). There are no spaces in this title, and it must be enclosed in square brackets.
Value= : Specify the unique keyword that identifies the recipient. Multiple keywords can be included if they are
separated by a comma. This keyword must be included in the body of the message as the first item, followed by
or

.

Caution: Keyword values are case sensitive. The keyword in an incoming message must match this value exactly
or the message cannot be delivered.
•
•

Mailbox= : Enter the mailbox for the recipient. The incoming SMS message will be delivered here.
Company= : For sites that have multiple tenants / companies, enter the company number for this user here.
This value must match the company numbers defined on the Avaya Messaging Voice Server. In most cases,
where there is only a single company configured, set this value to 1.

Avaya Messaging Feature Description Guide

326

Integration with Avaya CPaaS

3.

Once all users have been added, save the file with the name: http2smsconnector.ini
Save it on the Messaging Voice Server installation drive in the UC/SMS folder.

4.

Stop and re-Start the UC SMSConnector service on the Voice Server, or reboot the server.
This service should also be configured to start automatically.

All incoming SMS messages sent to the Avaya CPaaS telephone number will be directed to the user’s mailbox using both
the addressing within the body of the message and the entry within the INI file.
Note: You can combine both Keyword and Direct number entries in the same INI file. Only the
information in each entry will change.

[Keyword1]
Value= ASKJohnC,JohnC
Mailbox= 9876
Company= 1
[Application1]
Number= 1(905)707-9700
Mailbox= 9876
Company= 1
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Addressing SMS Messages
Once the Avaya CPaaS telephone number has been purchased and Avaya Messaging configured to use it, messages sent
to that number will be received in the recipient’s inbox.
Contacts wishing to send a message to the user address it to the Avaya CPaaS telephone number. Additional addressing
by the sender may be required.

Personal number
The sender only needs to provide the number (e.g. 442030026798) to address the message.

The Voice Server spots the telephone number and uses the Messaging Admin Addresses tab to direct the message to the
correct mailbox.
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Direct number
Enter the recipient’s Avaya CPaaS telephone number (e.g. 1(905)707-9700) exactly as it is configured in the INI file.

The Voice Server spots the telephone number and uses the INI file to direct the message to the correct mailbox.

Avaya Messaging Feature Description Guide

329

Integration with Avaya CPaaS

Mailbox
The sender must include the recipient’s mailbox number in the body of the message. The number must be preceded by
## (e.g. ##9876).

The ## marker tells the server that the number that follows is the extension of the recipient and the message is delivered
accordingly.
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Keyword
The sender must include the keyword exactly as it is configured for that user in the INI file (e.g. ASKJohnC). The keyword
is case sensitive.

The Voice Server spots the keyword and uses the INI file to direct the message to the correct mailbox.
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Introduction
Logging in to an application using Avaya credentials provides a web-based authentication solution (OnEsna) for sites
where Gmail and Salesforce are not available. Creating a user account with OnEsna allows access to a range of programs
using secure access protocols.

Creating an Account with OnEsna
Before attempting to login using Avaya credentials for the first time, it is necessary to
create an account at OnEsna.
1.

Open a browser and go to https://accounts.zang.io.

2.

At the login screen, click Create an account.

3.

On the Sign Up screen, enter your corporate email address, your first and last
names, and the password you want to use with OnEsna. Re-enter the password
to confirm.
When finished, click Sign Up.

4.

A confirmation email will be sent to the address provided.
Open the message and click Verify Email.

5.

OnEsna account setup is complete. Click Login.
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Logging In Through OnEsna
Important: The system administrator can enable a security policy to limit the
login credentials available. Contact your administrator for more information.
For all applications, the login procedure is the same when you select Email Credentials to start the program.
1.

At the login page, choose Email account

from the drop down list.

Hint: From the Connection page, click the Utility Menu and select Clear credentials to delete all login details
and restart the login procedure.
2.

When prompted, enter your username and password. Click Login.

Note: Enable Keep me logged in to have OnEsna automatically use the
same credentials on all subsequent login attempts. You will be seamlessly
logged in to all client extension each time the browser is launched.

3.

If prompted to grant Avaya iLink permissions, click Accept.

Note: This only needs to be done the first time you login to the client.
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4.

The Avaya iLink client will start.

Note: In order for the program to save your settings, you must allow your web browser to accept 3rd party
cookies. Some browsers may reject 3rd party cookies either as a default setting or through an organizational
policy.
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Introduction
Avaya Messaging provides greater accessibility to people with special needs. Messaging offers 508 compliance and TTY
integration.

508 Compliance
Complying with the 508 standard in Messaging means that the user interface for a program must be usable to clients
without the use of a mouse. The user interface for launching and navigating through the Web Access program provides
access to all areas using the keyboard alone.
The keyboard commands are shown here:
KEYSTROKE

FUNCTION
Skip to next item.

+
or

Return to the previous item.
Enable or Select the current item.
Expand / Collapse menus.
Scroll Up and Down within a menu.
Toggle the current radio button.
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The login, splash screen and Web Access interface are all 508 compliant.

Open menu
Scroll

Enable Checkbox
Cycle through Radio Buttons
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TTY Integration
Avaya Messaging includes support for TTY devices on your corporate voicemail system. TTY compatibility is provided
through a language pack which can be downloaded from PLDS.
Install the language pack according to the instructions found in the Server Installation Guide under Language Pack
Installation on page 519.
Once the language pack for TTY English has been installed, it can be chosen as the default language for your company
and for each user’s mailbox.

Hint: It is recommended that a separate telephone number be used for the company for TTY language
prompts. This prevents TTY callers from getting no response on their device from a voice enabled system, and
hearing callers receiving unintelligible signals on their handset from the TTY service.

Voice Recordings and TTY
The TTY system automatically converts system prompts into signals compatible with TTY devices. However, voice
recordings made on-site cannot be converted.
To build greetings that appear on TTY devices, the greeting must be typed into a software program that converts the text
into a TTY compatible audio format, which is then saved as a WAV file. These audio files can then be uploaded into
Messaging to replace the voice recordings for that company with TTY prompts.

Note: It is recommended that the TTY feature be used only with shorter messages and prompts, such as
for managing your mailbox and for internal transfers. For use with longer texts, such as with the Telephone
User Interface (TUI), using Messaging Web Access is preferred.
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Appendix A: Revision History
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Initial Document Release.

4 November, 2019

10.8 (2)

Added new chapter on integrating Office 365
using Microsoft Graph.

19 November, 2019

10.8 (3)

Removed outdated content.

6 January, 2020

10.8 (4)

Rebuilt OAuth 2 / Google integration
configuration to match the current state.
Updated chapters on EWS for Office 365 and
Exchange integration to match current state.
Added navigation table to direct users to the
correct chapter (8-13) for CSE integrations.

28 January, 2020

10.8 (5)

Added notes to Web Access and UM Monitor re:
best to use Chrome.

8 April, 2020

10.8 (6)

Changed download location for the
Accessibility application to PLDS from
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Updated procedure for installing Remote
Printer.
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Updated the SR140 configuration procedure.

13 May, 2020

10.8 (9)

Removed some outdated references to TSE in
favor of CSE.

17 June, 2020

10.8 (10)

Corrected some minor wording issues.

12 August, 2020

10.8 (11)

Add a note to the Email to Fax instructions for
the admin to create an MX record pointing
vpim.esna.com to the IXM voice server.

30 October, 2020

10.8 (12)

New step added for configuring SR140 to work
with IX Messaging.

9 March, 2021

10.8 (13)

Updated Mutare configuration tool details
(which servers to use, URL callback).

11 March, 2021

10.8 (14)

Added notes on the use of MRCP for ASR.

30 March, 2021

10.8 (15)

New note reminding users to reapply
configuration for MSGraph integration after
updating the program.

22 April, 2021

10.8 (16)

Added note regarding that transcription only
works for voice messages.

29 April, 2021

10.8 (17)

Updated instructions for Office 365 integration
using EWS. Note regarding HA time zones all
being the same.
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Change Summary

12 October, 2021

10.8 (18)

Updated the ASR section to include verification
of the license when using WebLM.

14 October, 2021

10.8 (19)

Updated the OAuth 2 configuration section.
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